Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1361618 - Gray mask renders UI unusable
Summary: Gray mask renders UI unusable
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.6.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.7.0
Assignee: Dan Clarizio
QA Contact: Matouš Mojžíš
URL:
Whiteboard: ui:filter
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-29 14:18 UTC by David La Motta
Modified: 2017-06-14 21:08 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-14 21:08:50 UTC
Category: ---
Cloudforms Team: ---


Attachments (Terms of Use)
Gray mask (deleted)
2016-07-29 14:37 UTC, David La Motta
no flags Details

Description David La Motta 2016-07-29 14:18:17 UTC
Description of problem:
After running a custom filter the web UI shows a gray mask, which renders the UI unusable. I've seen this happen in an environment with > 2000 VMs and another with < 20 VMs. Env size apparently doesn't matter.

Version-Release number of selected component (if applicable):
5.6.0.13.20160624114606_13a9153 

How reproducible:
Not always, which is the bad part.

Steps to Reproduce:
1. Create a custom filter for virtual machines
2. Apply the filter
3. Watch the screen go gray and never recover

Actual results:
There is a gray mask applied to the screen.

Expected results:
The filter is applied and the mask is removed after the filter is applied.

Additional info:
Ralph Lauren is hitting this issue. The workaround is to refresh the browser, re-run the filter and cross our fingers that the problem doesn't show again. I've seen this happen in Chrome and in Firefox.

Comment 6 David La Motta 2016-07-29 14:37:56 UTC
Created attachment 1185577 [details]
Gray mask

Comment 8 Matouš Mojžíš 2016-08-08 12:41:18 UTC
Can't reproduce it.

David, could you give me example of filter, which is making this gray mask?

I have already seen this gray mask after applying filter with user input, but can't reproduce it in this version.

Comment 9 Dan Clarizio 2017-06-13 21:15:07 UTC
David, can you reply to Matous' comment above please?  Thx, Dan

Comment 10 David La Motta 2017-06-13 23:49:20 UTC
I can't reproduce this, either, on 5.8.0.17.20170525183055_6317a22.

I tested a filter just now without user input, and I hit no issues.

I am okay if we close this BZ as unreproducible.


Note You need to log in before you can comment on or make changes to this bug.