Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1361582 - Link of the Download as * is constructed dynamically on the client side
Summary: Link of the Download as * is constructed dynamically on the client side
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.6.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: GA
: 5.7.0
Assignee: Martin Povolny
QA Contact: Jaroslav Henner
URL:
Whiteboard: general:ui
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-29 12:49 UTC by Jaroslav Henner
Modified: 2017-12-08 15:00 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-16 10:00:52 UTC
Category: ---
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jaroslav Henner 2016-07-29 12:49:55 UTC
Description of problem:
The CFME web ui testing of download links of the table in various formats is not easy to automate in Selenium because the links of the "Download as *" buttons are constructed in the javascript.


Version-Release number of selected component (if applicable):
5.6.0.13.20160624114606_13a9153

How reproducible:
Always

Steps to Reproduce:
1. Navigate to https://YOUR_CFME/ems_container/show_list?page=1&refresh=y
2. Inspect the "Download as" button
3.




Actual results:

<a title="Download this report in text format" name="download_choice__download_text" href="#" data-url_parms="?download_type=text" data-url="/download_data" data-click="download_choice__download_text">
<i class="fa fa-file-text-o fa-lg" style="margin-right: 5px;"/>
Download as Text
</a>


Expected results:
href="URL to the file."

Additional info:


Note You need to log in before you can comment on or make changes to this bug.