Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1361545 - ipa-client-install starts rhel-domainname.service but does not rpm-require it
Summary: ipa-client-install starts rhel-domainname.service but does not rpm-require it
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jan Cholasta
QA Contact: Kaleem
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-29 11:51 UTC by Jan Pazdziora
Modified: 2016-11-04 05:59 UTC (History)
2 users (show)

Fixed In Version: ipa-4.4.0-6.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 05:59:39 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Jan Pazdziora 2016-07-29 11:51:25 UTC
Description of problem:

ipa-client-install starts rhel-domainname.service but its package (or its dependencies) do not rpm-require initscripts that would the service. This causes issues in containers where initscripts is not installed by default and latest IPA packages (and their dependencies) do not bring initscipts in.

Version-Release number of selected component (if applicable):

python2-ipalib-4.4.0-3.el7.noarch

How reproducible:

Deterministic.

Steps to Reproduce:
1. Run ipa-server-install on system (in container) where initscripts package is not installed.

Actual results:

Addressing
Traceback (most recent call last):
  File "/usr/sbin/ipa-client-install", line 3127, in <module>
    sys.exit(main())
  File "/usr/sbin/ipa-client-install", line 3108, in main
    rval = install(options, env, fstore, statestore)
  File "/usr/sbin/ipa-client-install", line 3075, in install
    configure_nisdomain(options=options, domain=cli_domain)
  File "/usr/sbin/ipa-client-install", line 1525, in configure_nisdomain
    services.knownservices.domainname.restart()
  File "/usr/lib/python2.7/site-packages/ipaplatform/base/services.py", line 301, in restart
    skip_output=not capture_output)
  File "/usr/lib/python2.7/site-packages/ipapython/ipautil.py", line 488, in run
    raise CalledProcessError(p.returncode, arg_string, str(output))
subprocess.CalledProcessError: Command '/bin/systemctl restart rhel-domainname.service' returned non-zero exit status 6
ipa.ipapython.install.cli.install_tool(Server): ERROR    Configuration of client side components failed!
ipa.ipapython.install.cli.install_tool(Server): ERROR    The ipa-server-install command failed. See /var/log/ipaserver-install.log for more information

Expected results:

No error.

Additional info:

Comment 2 Petr Vobornik 2016-08-03 12:11:02 UTC
Dependency needs to be added. 

Still unclear if upstream/Fedora is also affected.

Comment 3 Petr Spacek 2016-08-08 11:21:06 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/4831

Comment 4 Jan Cholasta 2016-08-10 05:36:37 UTC
Fixed upstream
master:
https://fedorahosted.org/freeipa/changeset/771dea5c6bf1cca7b3756d2f1be48f613de14ceb

Comment 6 Kaleem 2016-09-23 12:32:09 UTC
Verified. 

[root@dhcp207-129 ~]# rpm -q --requires ipa-client|grep init
initscripts
[root@dhcp207-129 ~]# rpm -q ipa-server ipa-client
ipa-server-4.4.0-12.el7.x86_64
ipa-client-4.4.0-12.el7.x86_64
[root@dhcp207-129 ~]#

Comment 8 errata-xmlrpc 2016-11-04 05:59:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.