Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1361507 - ThinkPad T460s has stopped routing audio through the docking station in F24
Summary: ThinkPad T460s has stopped routing audio through the docking station in F24
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: alsa-lib
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jaroslav Kysela
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-29 08:37 UTC by Alberto Ruiz
Modified: 2016-07-29 15:51 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-29 09:17:39 UTC


Attachments (Terms of Use)

Description Alberto Ruiz 2016-07-29 08:37:53 UTC
Description of problem:
My ThinkPad T460s has stopped routing audio through the docking station in F24

How reproducible:
Always

Steps to Reproduce:
1. Dock the laptop
2. Play a sound

Actual results:
Sound is outed through the laptop speakers instead of the dock. PulseAudio won't show that there are now two outputs (docks' minijack and the speakers as it did in F23)

Expected results:
Audio output to be routed through the dock, at least in the case that there's something plugged in the minijack.

Comment 1 Frediano Ziglio 2016-07-29 08:48:22 UTC
Just an idea. Did you try to use the F23 kernel with F24 ?

Comment 2 Alberto Ruiz 2016-07-29 09:17:28 UTC
I think the problem was in the dock somehow, I unplugged the minijack from the dock and plugged it again and now everything is fine. Sorry guys.

Comment 3 Jonathon Jongsma 2016-07-29 15:45:10 UTC
I have a T460p, and the dock jack still does not work for me. However, It looks like my behavior is a little bit different than yours. You said that when you have it docked and something plugged into the dock minijack, you still get audio through your laptop speakers. If I have my laptop docked and nothing plugged into the dock's audio jack, I get sound through my built-in laptop speakers. If I plug some speakers into the into the dock's audio jack, I get no sound at all. Unplugging and re-plugging does not help at all.

Comment 4 Alberto Ruiz 2016-07-29 15:51:00 UTC
I think in my case it was some weird problem with the dock not detecting the jack that was in. Since I replugged the jack everything is fine now.


Note You need to log in before you can comment on or make changes to this bug.