Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1361486 - Chromium crashes on certain web pages due to gcc6 optimization
Summary: Chromium crashes on certain web pages due to gcc6 optimization
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: chromium
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-29 07:14 UTC by Whistler
Modified: 2016-07-30 06:51 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-30 06:51:42 UTC


Attachments (Terms of Use)

Description Whistler 2016-07-29 07:14:05 UTC
Description of problem:

When browsing certain web pages, chromium crash 100%.

Version-Release number of selected component (if applicable):
52.0.2743.82

How reproducible:
Always

Steps to Reproduce:
1. Visit http://weimzh.com/wiki.html

Actual results:
Crash 100% immediately

Expected results:
web page works normally

Additional info:
According to https://gcc.gnu.org/bugzilla/show_bug.cgi?id=68853
optimization in gcc6 causes problem when chromium, and -fno-delete-null-pointer-checks parameter is required for certain codes of chromium to function properly.

Comment 1 Tom "spot" Callaway 2016-07-29 12:16:49 UTC
Cannot reproduce on chromium-52.0.2743.82-9.fc24.x86_64. Please test with the latest pending update:

https://bodhi.fedoraproject.org/updates/FEDORA-2016-dc48263ff8

Comment 2 Whistler 2016-07-30 06:51:42 UTC
chromium-52.0.2743.82-9.fc24.x86_64 = no problem.
Thanks.


Note You need to log in before you can comment on or make changes to this bug.