Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1361478 - Failed to resolve ipv6 address
Summary: Failed to resolve ipv6 address
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: spice-gtk
Version: 7.3
Hardware: x86_64
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Pavel Grunt
QA Contact: SPICE QE bug list
URL:
Whiteboard:
Depends On:
Blocks: 1362394
TreeView+ depends on / blocked
 
Reported: 2016-07-29 06:59 UTC by Xiaodai Wang
Modified: 2016-11-04 01:23 UTC (History)
6 users (show)

Fixed In Version: spice-gtk-0.31-5.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1362394 (view as bug list)
Environment:
Last Closed: 2016-11-04 01:23:17 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2229 normal SHIPPED_LIVE virt-viewer, libgovirt, spice-gtk, and usbredir bug fix and enhancement update 2016-11-03 13:26:58 UTC

Description Xiaodai Wang 2016-07-29 06:59:38 UTC
Description of problem:
Failed to resolve ipv6 address

Version-Release number of selected component (if applicable):
virt-viewer-2.0-11.el7.x86_64
spice-gtk-0.31-4.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Prepare a guest and make sure it's listen address is "::".
    <graphics type='spice' port='5900' autoport='yes' listen='0::0'>
      <listen type='address' address='0::0'/>
    </graphics>
2. Open the guest by remote-viewer.
$ remote-viewer spice://[::1]:5900

Actual results:
"Unable to connect to the graphic server spice://[::1]:5900" dialog pops up.
Error reseason is "Error resolving '[::1]': Name or service not known

Expected results:
The guest should be connected successfully.

Additional info:
This issue doesn't occur with spice-gtk-0.31-3.el7.x86_64

Comment 4 Pavel Grunt 2016-07-29 14:19:08 UTC
Fixed by: 5a301b201be77c0ece71640ba99e92733a93f950

Comment 8 errata-xmlrpc 2016-11-04 01:23:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2229.html


Note You need to log in before you can comment on or make changes to this bug.