Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1361442 - qt5-qtwebengine update segfault.
Summary: qt5-qtwebengine update segfault.
Keywords:
Status: CLOSED DUPLICATE of bug 1364781
Alias: None
Product: Fedora
Classification: Fedora
Component: qt5-qtwebengine
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kevin Kofler
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-29 05:50 UTC by eddy02
Modified: 2016-08-16 03:04 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-16 03:04:02 UTC


Attachments (Terms of Use)

Description eddy02 2016-07-29 05:50:47 UTC
Qupzilla crashes since qtwebengine update to 5.7.

Blank and blinking white pages then core dump.




Time: ven. juil. 29 07:39:05 2016
Qt version: 5.7.0 (compiled with 5.6.1)
QupZilla version: 2.0.1
Rendering engine: QtWebEngine

============== BACKTRACE ==============
#0: qupzilla(+0x3512) [0x56411c524512]
#1: /lib64/libc.so.6(+0x35940) [0x7efc5b015940]
#2: /lib64/libQt5WebEngineCore.so.5(+0x659ec6) [0x7efc5dfd4ec6]
#3: /lib64/libQt5WebEngineCore.so.5(+0x12e2c21) [0x7efc5ec5dc21]
#4: /lib64/libQt5WebEngineCore.so.5(+0x1259bad) [0x7efc5ebd4bad]
#5: /lib64/libQt5WebEngineCore.so.5(+0x12e4e9a) [0x7efc5ec5fe9a]
#6: /lib64/libQt5WebEngineCore.so.5(+0x11d1d1e) [0x7efc5eb4cd1e]
#7: /lib64/libQt5WebEngineCore.so.5(+0x11d3082) [0x7efc5eb4e082]
#8: /lib64/libQt5WebEngineCore.so.5(+0x11d33b8) [0x7efc5eb4e3b8]
#9: /lib64/libQt5WebEngineCore.so.5(+0x11d3810) [0x7efc5eb4e810]
#10: /lib64/libQt5WebEngineCore.so.5(+0x13dea07) [0x7efc5ed59a07]
#11: /lib64/libQt5WebEngineCore.so.5(+0x13df0b2) [0x7efc5ed5a0b2]
#12: /lib64/libQt5WebEngineCore.so.5(+0x11b4e05) [0x7efc5eb2fe05]
#13: /lib64/libQt5WebEngineCore.so.5(+0x11b507e) [0x7efc5eb3007e]
#14: /lib64/libQt5WebEngineCore.so.5(+0x11b56cf) [0x7efc5eb306cf]
#15: /lib64/libQt5WebEngineCore.so.5(+0x11b59bf) [0x7efc5eb309bf]
#16: /lib64/libQt5WebEngineCore.so.5(_ZN15QtWebEngineCore18WebContentsAdapter10setContentERK10QByteArrayRK7QStringRK4QUrl+0x414) [0x7efc5dfc9c74]
#17: /lib64/libQt5WebEngineWidgets.so.5(_ZN14QWebEnginePage7setHtmlERK7QStringRK4QUrl+0x45) [0x7efc631456f5]
#18: /lib64/libQupZilla.so.2(+0x27c0a9) [0x7efc62c2b0a9]
#19: /lib64/libQt5Core.so.5(+0x279266) [0x7efc5c35d266]
#20: /lib64/libQt5Core.so.5(_ZN7QObject5eventEP6QEvent+0x9b) [0x7efc5c35208b]
#21: /lib64/libQt5Widgets.so.5(_ZN19QApplicationPrivate13notify_helperEP7QObjectP6QEvent+0x9c) [0x7efc5d08496c]
#22: /lib64/libQt5Widgets.so.5(_ZN12QApplication6notifyEP7QObjectP6QEvent+0x261) [0x7efc5d08c111]
#23: /lib64/libQt5Core.so.5(_ZN16QCoreApplication15notifyInternal2EP7QObjectP6QEvent+0xaa) [0x7efc5c32a12a]
#24: /lib64/libQt5Core.so.5(_ZN14QTimerInfoList14activateTimersEv+0x37b) [0x7efc5c37738b]
#25: /lib64/libQt5Core.so.5(+0x2938e1) [0x7efc5c3778e1]
#26: /lib64/libglib-2.0.so.0(g_main_context_dispatch+0x162) [0x7efc5a06dde2]
#27: /lib64/libglib-2.0.so.0(+0x4a160) [0x7efc5a06e160]
#28: /lib64/libglib-2.0.so.0(g_main_context_iteration+0x2c) [0x7efc5a06e20c]
#29: /lib64/libQt5Core.so.5(_ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE+0x5f) [0x7efc5c377d6f]
#30: /lib64/libQt5Core.so.5(_ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE+0xfa) [0x7efc5c3290ba]
#31: /lib64/libQt5Core.so.5(_ZN16QCoreApplication4execEv+0x9c) [0x7efc5c330bac]
#32: qupzilla(+0x2aa7) [0x56411c523aa7]
#33: /lib64/libc.so.6(__libc_start_main+0xf1) [0x7efc5b000401]
#34: qupzilla(+0x2dca) [0x56411c523dca]

Comment 1 eddy02 2016-07-29 06:20:03 UTC
Just tried latest qupzilla koji build, nearly same issue.

Wondering if related to chromium rendering (blank and white page to). 

Qupzilla:
0729/081653:ERROR:browser_main_loop.cc(217)] Running without the SUID sandbox! See https://chromium.googlesource.com/chromium/src/+/master/docs/linux_suid_sandbox_development.md for more information on developing with the sandbox on.
QupZilla: 8 extensions loaded

I just filed a bug report for chromium sandbox issue.


Time: ven. juil. 29 08:01:02 2016
Qt version: 5.7.0 (compiled with 5.7.0)
QupZilla version: 2.0.1
Rendering engine: QtWebEngine

============== BACKTRACE ==============
#0: qupzilla(+0x3512) [0x5573c0850512]
#1: /lib64/libc.so.6(+0x35940) [0x7f3fcb537940]
#2: /lib64/libQt5Core.so.5(_ZN23QCoreApplicationPrivate29sendThroughObjectEventFiltersEP7QObjectP6QEvent+0xa7) [0x7f3fcc84beb7]
#3: /lib64/libQt5Widgets.so.5(_ZN19QApplicationPrivate13notify_helperEP7QObjectP6QEvent+0x75) [0x7f3fcd5a6945]
#4: /lib64/libQt5Widgets.so.5(_ZN12QApplication6notifyEP7QObjectP6QEvent+0x111d) [0x7f3fcd5aefcd]
#5: /lib64/libQt5Core.so.5(_ZN16QCoreApplication15notifyInternal2EP7QObjectP6QEvent+0xaa) [0x7f3fcc84c12a]
#6: /lib64/libQt5Widgets.so.5(_ZN19QApplicationPrivate14sendMouseEventEP7QWidgetP11QMouseEventS1_S1_PS1_R8QPointerIS0_Eb+0x1dd) [0x7f3fcd5ad65d]
#7: /lib64/libQt5Widgets.so.5(+0x1bbdd0) [0x7f3fcd607dd0]
#8: /lib64/libQt5Widgets.so.5(+0x1be603) [0x7f3fcd60a603]
#9: /lib64/libQt5Widgets.so.5(_ZN19QApplicationPrivate13notify_helperEP7QObjectP6QEvent+0x9c) [0x7f3fcd5a696c]
#10: /lib64/libQt5Widgets.so.5(_ZN12QApplication6notifyEP7QObjectP6QEvent+0x261) [0x7f3fcd5ae111]
#11: /lib64/libQt5Core.so.5(_ZN16QCoreApplication15notifyInternal2EP7QObjectP6QEvent+0xaa) [0x7f3fcc84c12a]
#12: /lib64/libQt5Gui.so.5(_ZN22QGuiApplicationPrivate17processMouseEventEPN29QWindowSystemInterfacePrivate10MouseEventE+0x753) [0x7f3fcd09ce73]
#13: /lib64/libQt5Gui.so.5(_ZN22QGuiApplicationPrivate24processWindowSystemEventEPN29QWindowSystemInterfacePrivate17WindowSystemEventE+0x135) [0x7f3fcd09e925]
#14: /lib64/libQt5Gui.so.5(_ZN22QWindowSystemInterface22sendWindowSystemEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE+0xbb) [0x7f3fcd07f7cb]
#15: /lib64/libQt5XcbQpa.so.5(+0x71c60) [0x7f3fbf2b3c60]
#16: /lib64/libglib-2.0.so.0(g_main_context_dispatch+0x162) [0x7f3fca51cde2]
#17: /lib64/libglib-2.0.so.0(+0x4a160) [0x7f3fca51d160]
#18: /lib64/libglib-2.0.so.0(g_main_context_iteration+0x2c) [0x7f3fca51d20c]
#19: /lib64/libQt5Core.so.5(_ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE+0x5f) [0x7f3fcc899d6f]
#20: /lib64/libQt5Core.so.5(_ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE+0xfa) [0x7f3fcc84b0ba]
#21: /lib64/libQt5Core.so.5(_ZN16QCoreApplication4execEv+0x9c) [0x7f3fcc852bac]
#22: qupzilla(+0x2aa7) [0x5573c084faa7]
#23: /lib64/libc.so.6(__libc_start_main+0xf1) [0x7f3fcb522401]
#24: qupzilla(+0x2dca) [0x5573c084fdca]

Comment 2 Kevin Kofler 2016-07-29 09:25:58 UTC
I need a backtrace with debugging information to understand what is going on here.

Comment 3 eddy02 2016-08-15 21:48:33 UTC
Latest qtwebengine build is ok , qupzilla runs again.

And good job, your patch help me to solve chromium f25+ issue.

Thanks a lot and sorry for py english.

Comment 4 Kevin Kofler 2016-08-16 03:04:02 UTC

*** This bug has been marked as a duplicate of bug 1364781 ***


Note You need to log in before you can comment on or make changes to this bug.