Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1361365 - upgrading katello-agent after a satellite 6.2 upgrade should be mentioned earlier in install doc.
Summary: upgrading katello-agent after a satellite 6.2 upgrade should be mentioned ear...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Docs Install Guide
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Stephen Wadeley
QA Contact: Russell Dickenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-28 23:20 UTC by Kathryn Dixon
Modified: 2016-08-02 14:25 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-02 14:25:06 UTC


Attachments (Terms of Use)

Description Kathryn Dixon 2016-07-28 23:20:56 UTC
Document URL: https://access.redhat.com/documentation/en/red-hat-satellite/6.2/single/installation-guide/#upgrading_satellite_server_and_capsule_server

Section Number and Name: Chapter 6. Upgrading Satellite Server and Capsule Server

Describe the issue: 

There should be another note under this time note about how you will also need to plan time for upgrading katello-agent by hand, if this isn't done before upgrading the satellite.

Note

Upgrading from Satellite or Capsule 6.1 to 6.2 is a lengthy operation that can take many hours depending on the size of the repositories on the Satellite or Capsule. The upgrade processing rate for the content of /var/lib/pulp/ is estimated at between 50 GB and 100 GB per hour. If you have 500 GB of content, the upgrade could take from 5 to 10 hours. 

Suggestions for improvement: Add that information from 6.5 section 

You must manually upgrade to the new version of katello-agent so that your client is compatible with Satellite Server. 

there should also be an "or" upgrade katello-agent ( after refreshing the manifest and syncing sat tools 6.2 ) before upgrading the satellite 6.2 if engineering agrees.

Additional information:

Comment 1 Stephen Wadeley 2016-07-29 06:46:26 UTC
Hello

Thank you for raising this bug.

Comment 3 Stephen Wadeley 2016-07-29 08:11:45 UTC
Notes to self

"Add that information from 6.5 section"

that means from "Upgrading Satellite Clients" section 

https://access.redhat.com/documentation/en/red-hat-satellite/6.2/single/installation-guide/#upgrading_clients

Comment 4 Stephen Wadeley 2016-07-29 15:28:26 UTC
Hello Kathryn

I see there was a sentence about this already, for the moment I have just made it into a new para and add a link to the "Upgrading Satellite Clients" section.

Was: You must also manually upgrade Satellite clients to the new version of katello-agent after upgrading the Satellite Server and Capsule Servers.

Will be: You must also manually upgrade Satellite clients to the new version of katello-agent after upgrading the Satellite Server and Capsule Servers. See Upgrading Satellite Clients for more information.

That update will be published today.

Lets ask Chris Duryee if there is anything more we can say on this subject.

Thank you

Comment 6 Chris Duryee 2016-07-29 16:09:04 UTC
The change in comment #4 looks good to me.

Comment 7 Stephen Wadeley 2016-08-02 14:24:37 UTC
Hello


The change as per comment 4 is now live on the customer portal.

As per comment 6 this is now VERIFIED, but as the change is already published I will also close the bug. Please feel free to re-open if more information becomes available on this subject that needs to be added to that section.

Thank you


Note You need to log in before you can comment on or make changes to this bug.