Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1361311 - OSE Master/Nodes Page: "Resources Available" tooltip only appears when 30GB additional storage is selected.
Summary: OSE Master/Nodes Page: "Resources Available" tooltip only appears when 30GB a...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: WebUI
Version: 1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ga
: 1.0
Assignee: Derek Whatley
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-28 18:42 UTC by bmorriso
Modified: 2016-08-04 18:32 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-04 18:32:58 UTC


Attachments (Terms of Use)
Tooltip when 30GB is selected (deleted)
2016-07-28 18:42 UTC, bmorriso
no flags Details
Tooltip when 25GB is selected (deleted)
2016-07-28 18:43 UTC, bmorriso
no flags Details
ose tooltip in the latest dev environment (deleted)
2016-08-01 20:21 UTC, Derek Whatley
no flags Details
ose tooltip in QCI-1.0-RHEL-7-20160729.t.0-QCI-x86_64-dvd1.iso (deleted)
2016-08-01 20:22 UTC, Derek Whatley
no flags Details
ose tooltip in the latest dev environment (deleted)
2016-08-01 20:41 UTC, Derek Whatley
no flags Details

Description bmorriso 2016-07-28 18:42:39 UTC
Created attachment 1185250 [details]
Tooltip when 30GB is selected

Description of problem:
In the New Deployment wizard, on the Openshift Master/Nodes selection page,
the "Resources Available" tooltip that is inside the Environment Summary section only appears when the default additional storage value of 30GB is selected. If a different storage value is selected, the tooltip doesn't appear. Attached screenshots show the issue.

Version-Release number of selected component (if applicable):
QCI-1.0-RHEL-7-20160727.t.0

How reproducible:
100%

Steps to Reproduce:
1. Start a new deployment with OSE selected
2. Navigate through wizard to the Master/Nodes page
3. Select different values for additional storage and hover over the
environment summary tooltip.

Actual results:
Tooltip only appears when 30GB is selected

Expected results:
Tooltip should appear regardless of storage selection

Additional info:

Comment 1 bmorriso 2016-07-28 18:43:02 UTC
Created attachment 1185251 [details]
Tooltip when 25GB is selected

Comment 3 Derek Whatley 2016-08-01 20:21:24 UTC
Created attachment 1186533 [details]
ose tooltip in the latest dev environment

Comment 4 Derek Whatley 2016-08-01 20:22:34 UTC
Created attachment 1186534 [details]
ose tooltip in QCI-1.0-RHEL-7-20160729.t.0-QCI-x86_64-dvd1.iso

Comment 5 Derek Whatley 2016-08-01 20:34:23 UTC
Not able to replicate issue on QCI-1.0-RHEL-7-20160729.t.0 or most recent dev environment.

Screenshots attached of results found in both environments.

Files below show no changes between 7-27 build and 7-29.

Change History for "ose-env-summary.js"
https://github.com/fusor/fusor/commits/master/fusor-ember-cli/app/components/ose-env-summary.js

Change History for  "ose-env-summary.hbs"
https://github.com/fusor/fusor/commits/master/fusor-ember-cli/app/templates/components/ose-env-summary.hbs


Question for bmorriso: did you include CFME in your deploy? If so, it's possible that the tooltip showing up at all was a bug.

Currently spinning up QCI-1.0-RHEL-7-20160727.t.0 (exact match BZ origin ISO) to attempt replication.

Comment 6 Derek Whatley 2016-08-01 20:41:37 UTC
Created attachment 1186536 [details]
ose tooltip in the latest dev environment

Comment 7 Derek Whatley 2016-08-02 14:54:36 UTC
Failed to replicate on QCI-1.0-RHEL-7-20160727.t.0-QCI-x86_64-dvd1.iso.

When performing RHEV+OSE+CFME deploy, tooltip consistently showed up across all tested versions. Without CFME (only RHEV+OSE), the tooltip was not visible.

Comment 8 bmorriso 2016-08-04 18:32:58 UTC
I can't reproduce this locally any more. It may have been an issue with my environment. Closing this out as NOTABUG.


Note You need to log in before you can comment on or make changes to this bug.