Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1361231 - GSS UI plugin is broken: SyntaxError: missing } after property list
Summary: GSS UI plugin is broken: SyntaxError: missing } after property list
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: redhat-support-plugin-rhev
Version: 4.0.2
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ovirt-4.0.2
: ---
Assignee: Alexander Wels
QA Contact: Pavel Novotny
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-28 14:46 UTC by Pavel Novotny
Modified: 2016-09-13 06:50 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-13 06:50:41 UTC
oVirt Team: Sub-Eng


Attachments (Terms of Use)

Description Pavel Novotny 2016-07-28 14:46:15 UTC
Description of problem:
GSS plugin contains syntax error and thus does not work at all.

Version-Release number of selected component (if applicable):
redhat-support-plugin-rhev-4.0.0-6.el7ev.noarch
rhevm-4.0.2.1-0.1.el7ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. Log into webadmin and select some entity, e.g., a data center, cluster, VM, ...
2. Look for the Red Hat Documentation sub-tab.
3.

Actual results:
Red Hat Documentation sub-tab is missing everywhere, because the plugin failed to load.
The browser console says:
SyntaxError: missing } after property list   ... start.html:35:2

Expected results:
No syntax errors.

Additional info:

Comment 2 Yaniv Kaul 2016-07-28 16:55:02 UTC
Isn't it a blocker?
Isn't it a regression?

Comment 4 Pavel Novotny 2016-07-28 17:24:23 UTC
(In reply to Yaniv Kaul from comment #2)
> Isn't it a blocker?

It is blocker, I raised the 'exception' flag instead of 'blocker'.

> Isn't it a regression?

It's first build for 4.0. In 3.6.8 it works.

Comment 5 Yaniv Kaul 2016-07-28 17:34:49 UTC
(In reply to Pavel Novotny from comment #4)

> > Isn't it a regression?
> 
> It's first build for 4.0. In 3.6.8 it works.

So it is a regression. Marking severity as Urgent, setting the 'Regression' keyword.

Comment 6 Pavel Novotny 2016-07-29 09:59:29 UTC
The severity of this is not urgent, moving back to high.

Comment 7 Oved Ourfali 2016-08-01 07:05:59 UTC
Spenser, are you on it?

Comment 8 Yaniv Lavi 2016-08-01 12:36:55 UTC
Can you have a look?

Comment 9 Spenser Shumaker 2016-08-01 12:40:28 UTC
Hey Oved,

I have not been involved in in-product integration in a long time.  I think awels is now the owner.  I am not sure how to transfer ownership of this bugzilla component.

Comment 10 Alexander Wels 2016-08-01 12:43:49 UTC
Yes I am the owner, I am taking a look right now.

Comment 11 Pavel Novotny 2016-08-02 14:33:26 UTC
Verified in redhat-support-plugin-rhev-4.0.0-7.el7ev.noarch

The GSS UI plugin is now loaded properly (no more errors in the browser console) and all 'Red Hat Documentation' sub-tabs are displayed.

Comment 13 Eyal Edri 2016-09-13 06:50:41 UTC
closing as current release as RHV 4.0 was GA'd, please reopen if needed.


Note You need to log in before you can comment on or make changes to this bug.