Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1361214 - netsniff-ng: wrong stats when pkt_type filter is enabled
Summary: netsniff-ng: wrong stats when pkt_type filter is enabled
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: netsniff-ng
Version: 7.3
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Eric Garver
QA Contact: xmu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-28 14:06 UTC by Paolo Abeni
Modified: 2017-01-23 12:41 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 06:14:06 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2419 normal SHIPPED_LIVE netsniff-ng bug fix and enhancement update 2016-11-03 13:58:46 UTC

Description Paolo Abeni 2016-07-28 14:06:02 UTC
When a packet type filter is used, netsniff-ng shows wrong results for both 'dropped' and 'unread' packets on exit.

see:
https://bugzilla.redhat.com/show_bug.cgi?id=1354445#c6
the first scenario, for a reproducer

Comment 1 Paolo Abeni 2016-07-29 09:35:30 UTC
fixed upstream with the commit:

commit da6e1d1108ad22d68ccbff07fb569afebb265bf7
Author: Paolo Abeni <pabeni@redhat.com>
Date:   Wed Jul 27 15:59:08 2016 +0200

    netsniff-ng: Account skipped packets as 'seen' and 'dropped'

Comment 9 errata-xmlrpc 2016-11-04 06:14:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2419.html


Note You need to log in before you can comment on or make changes to this bug.