Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1361158 - KDE 5 sometimes shows black screen with mouse cursor instead of lock screen (not possible to unlock session)
Summary: KDE 5 sometimes shows black screen with mouse cursor instead of lock screen (...
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: kwin
Version: 23
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Daniel Vrátil
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-28 12:17 UTC by Basic Six
Modified: 2016-12-20 21:17 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-20 21:17:00 UTC


Attachments (Terms of Use)

Description Basic Six 2016-07-28 12:17:21 UTC
Description of problem:

KDE 5 sometimes shows a black screen instead of the lock screen with a password prompt, so the user is locked out and has lost access to all running applications. Only the mouse cursor is visible and can be moved. A regular user would not know how to handle such a black screen and would be forced to do a cold reboot, losing all unsaved data and causing data loss or corruption.

An experienced user would switch to another tty (Ctrl + Alt + F2) and try a few commands. After "export DISPLAY=:0", several commands that are suggested online were tried without success, like "kquitapp5 plasmashell", "kstart5 plasmashell" and so on. Killing the kscreenlocker_greet process does not help either, it's just respawned.

What eventually helped was "kwin --replace". Going back to tty1, the black screen was gone and all the running applications were visible.

The panels are gone, but the applications are there so all work can be saved and nothing is lost.

Again, any regular user would not be able or know how to switch to another tty and run those commands. They'd just reboot and lose their data.



Version-Release number of selected component (if applicable):

plasmashell 5.7.1



How reproducible:

Not sure. After another modern desktop environment failed, I updated the system and started using KDE. After less than half a day, I was suddenly locked out, looking at a black screen.



Steps to Reproduce:
1. Use KDE 5.
2. Lock screen. Or maybe not. No idea.
3. Wait for surprise.



Actual results:

Black screen, locked out of session, lost access to running applications.



Expected results:

None of that.



Additional info:

Comment 1 Rex Dieter 2016-07-28 12:25:29 UTC
When/if it happens again, if you are familiar with gdb, try to get a backtrace from the seemingly-deadlocked kwin process.  That may give a clue what's going wrong.

Comment 2 Rex Dieter 2016-07-28 12:27:59 UTC
And, do you know what video hardware/driver you're using?

I suspect recent xorg-x11-server update:
https://bodhi.fedoraproject.org/updates/FEDORA-2016-a0ad95d1d7
may have something to do with it

Comment 3 Basic Six 2016-07-28 12:45:35 UTC
It's a ThinkPad laptop and I have not installed a custom or proprietary graphics driver.

$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)

$ egrep -i " connected|card detect|primary dev|Setting driver" /var/log/Xorg.0.log
[   174.184] (II) intel(0): Using Kernel Mode Setting driver: i915, version 1.6.0 20151010

$ uname -sr
Linux 4.4.2-301.fc23.x86_64

(The update installed a newer kernel but I'm using this one because the newer kernel broke VirtualBox.)

To your first question. If it happens again, I can maybe take a quick look at the kwin process. But for now, I'll switch to another desktop environment until this is fixed. KDE is nice, but such a serious bug is unacceptable.

Comment 4 Rex Dieter 2016-07-28 12:50:45 UTC
Are you using the modesetting driver on purpose (instead of xorg-x11-drv-intel)?

(Fwiw, I ran into similar issues once when testing modesetting, and ended up having to switch back to -drv-intel).


Sorry, I mispoke before, the referenced xorg-x11-server update was for f24, not f23, so that's not relevent here.

Comment 5 Basic Six 2016-07-28 13:38:24 UTC
No, not on purpose. As discussed on IRC, I have not changed any graphics settings manually.

Apparently, the Intel driver used to be recommended over the modesetting driver, but that appears to have changed in F24:
https://plus.google.com/+ThorstenLeemhuis/posts/YzEy1VGzU1U

I will upgrade to Fedora 24.

Comment 6 Fedora End Of Life 2016-11-25 09:28:27 UTC
This message is a reminder that Fedora 23 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 23. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '23'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 23 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 7 Fedora End Of Life 2016-12-20 21:17:00 UTC
Fedora 23 changed to end-of-life (EOL) status on 2016-12-20. Fedora 23 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.