Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1361148 - During major upgrade from osp-9 -> osp-10, yum -y -q update fails on controller.
Summary: During major upgrade from osp-9 -> osp-10, yum -y -q update fails on controller.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 10.0 (Newton)
Assignee: Jon Schlueter
QA Contact: Ido Ovadia
URL:
Whiteboard:
Depends On:
Blocks: 1337794
TreeView+ depends on / blocked
 
Reported: 2016-07-28 12:06 UTC by Sofer Athlan-Guyot
Modified: 2016-12-29 16:57 UTC (History)
14 users (show)

Fixed In Version: python-django-horizon-10.0.0-0.20161002185148.3252153.4.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 15:47:15 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC

Comment 2 Matthias Runge 2016-07-28 12:29:51 UTC
The following lines are missing in osp10s version of python-django-horizon.spec

mkdir -p %{buildroot}%{_sysconfdir}/openstack-dashboard/local_settings.d
mv %{buildroot}%{_datadir}/openstack-dashboard/openstack_dashboard/local/local_settings.d/* %{buildroot}%{_sysconfdir}/openstack-dashboard/local_settings.d
rmdir %{buildroot}%{_datadir}/openstack-dashboard/openstack_dashboard/local/local_settings.d
ln -s ../../../../..%{_sysconfdir}/openstack-dashboard/local_settings.d %{buildroot}%{_datadir}/openstack-dashboard/openstack_dashboard/local/local_settings.d

Comment 3 Jon Schlueter 2016-07-28 12:32:11 UTC
I'll work with RDO packaging to sync osp 9 packaging and rpm-master

Comment 6 Sofer Athlan-Guyot 2016-10-04 09:56:51 UTC
Any news on this one ?

Comment 13 Jon Schlueter 2016-10-12 14:07:54 UTC
From memory This was a case where osp 9 package has symlinks for folder, where OSP 10 packaging is missing the same change and instead currently has a folder in it's place.

Comment 14 Radomir Dopieralski 2016-10-12 14:16:53 UTC
I added the missing lines from comment 2 (I thought they were already added, but when I looked again, it turned out they were missing).

Comment 20 Sofer Athlan-Guyot 2016-10-14 11:12:49 UTC
Hi,

sorry I was using poodle, the package is still not there in the puddle.  Reading the needinfo flag then for marios comment 17.

Comment 21 Marios Andreou 2016-10-14 11:22:28 UTC
Well, even though you got it by mistake, your comment #18 I think then confirms that when we do eventually get the "Fixed In Version: python-django-horizon-10.0.0-0.20161002185148.3252153.4.el7ost" in puddle the problem is resolved.

Clearing the needinfo for now, radomir if you're lured here by needinfo spam and have a pointer to the packaging fix that added the missing spec lines please add it :)

I think it can stay on_qa for now and if we hit it after we get that package we can revisit

Comment 22 Radomir Dopieralski 2016-10-17 07:42:52 UTC
The fix is commit 64140372052884b6803ea63b336913eb9502d866 in the rhos-10.0-rhel-7 branch of python-django-horizon (I have no idea how I can link to the downstream git repos).

Comment 23 Omri Hochman 2016-11-15 18:55:07 UTC
unable to reproduce with: python-django-horizon-10.0.1-2.el7ost.noarch

Comment 25 errata-xmlrpc 2016-12-14 15:47:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.