Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1361091 - Policies explorer is recursive, doesn't show policies
Summary: Policies explorer is recursive, doesn't show policies
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.6.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.7.0
Assignee: Martin Hradil
QA Contact: Dmitry Misharov
URL:
Whiteboard: control:container:ui
: 1361001 1361215 1361859 (view as bug list)
Depends On:
Blocks: 1362181
TreeView+ depends on / blocked
 
Reported: 2016-07-28 10:36 UTC by Beni Paskin-Cherniavsky
Modified: 2017-01-12 05:13 UTC (History)
10 users (show)

Fixed In Version: 5.7.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1362181 (view as bug list)
Environment:
Last Closed: 2017-01-11 19:54:33 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)
screenshot of the problem (deleted)
2016-07-28 10:36 UTC, Beni Paskin-Cherniavsky
no flags Details


Links
System ID Priority Status Summary Last Updated
Github ManageIQ manageiq issues 10080 None None None 2016-07-28 10:36:16 UTC

Description Beni Paskin-Cherniavsky 2016-07-28 10:36:16 UTC
Created attachment 1185021 [details]
screenshot of the problem

**Happens on current master AND DARGA.  Requesting Z-stream clone to be blocker.**

Description of problem:
Control -> Explorer -> Policies accordion: explorer expands to infinite recursion, doesn't let you get to policies to see/edit them.

Version-Release number of selected component (if applicable):
darga (810a94fe507f27c5f727fe4df03a0c651e1e5d9e commit), and master.

Steps to Reproduce:
1. Go to Control -> Explorer -> Policies accordion.
2. Try to expand everything e.g. the built-in Container Image policies

Actual results:
See attached screenshot.
"▾ Container Image Control Policies" expands again to:
. Host Control Policies
. Vm Control Policies
...
▸ Container Image Control Policies

clicking the last one expands recursively to the same children, ad infinitum...
(same with compliance)

Expected results:
"▾ Container Image Control Policies" should expand to specific policies:
. Analyse incoming container images
. Schedule compliance after smart state analysis

Additional info:
Right-hand side does list correct children — specific policies, but clicking those doesn't let you open the policy (IIUC it relies on selecting it from explorer).

"Good" news is that it's still possible to add a new policy (standing on "{entity} {Compliance/Control} Policies"), after which the new policy — and other existing policies of this type — appear correctly in the explorer, so you can further edit them.
Fully expanding events under them will then show "Load error" instead of event's actions (https://bugzilla.redhat.com/show_bug.cgi?id=1360818), but you can see/edit actions on right side.

Comment 2 Martin Hradil 2016-07-28 11:54:25 UTC
Taking this one, because while this is a separate issue from https://bugzilla.redhat.com/show_bug.cgi?id=1360818 , the fix for both is the same.. https://github.com/ManageIQ/manageiq/pull/10110

Comment 3 Beni Paskin-Cherniavsky 2016-07-31 08:46:37 UTC
Sorry, forgot to request z-stream clone, setting 5.6.z? now.

Already fixed on master by
https://github.com/ManageIQ/manageiq/pull/10110
and on darga by
https://github.com/ManageIQ/manageiq/pull/10116

Comment 4 Beni Paskin-Cherniavsky 2016-07-31 08:48:21 UTC
*** Bug 1361001 has been marked as a duplicate of this bug. ***

Comment 5 Beni Paskin-Cherniavsky 2016-07-31 09:12:04 UTC
*** Bug 1361215 has been marked as a duplicate of this bug. ***

Comment 6 Pavel Zagalsky 2016-08-01 12:13:42 UTC
*** Bug 1361859 has been marked as a duplicate of this bug. ***

Comment 8 Dmitry Misharov 2016-09-09 08:42:35 UTC
Fixed and verified in 5.7.0.0.20160906172503_12f65cb. No more recursion in the policies tree.


Note You need to log in before you can comment on or make changes to this bug.