Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1361069 - Failure reason is lost when inputting command "nodectl rollback " in Terminal.
Summary: Failure reason is lost when inputting command "nodectl rollback " in Terminal.
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: ovirt-node
Classification: oVirt
Component: UI
Version: 4.0
Hardware: Unspecified
OS: Unspecified
high
medium vote
Target Milestone: ovirt-4.0.2
: 4.0
Assignee: Ryan Barry
QA Contact: Wei Wang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-28 09:49 UTC by Wei Wang
Modified: 2016-08-23 11:12 UTC (History)
9 users (show)

Fixed In Version: ovirt-node-ng-4.0.3-0.20160802.0.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 11:12:52 UTC
oVirt Team: Node
fdeutsch: ovirt-4.0.z?
rule-engine: planning_ack?
fdeutsch: devel_ack+
cshao: testing_ack+


Attachments (Terms of Use)
ks file (deleted)
2016-07-28 09:49 UTC, Wei Wang
no flags Details
log files (deleted)
2016-07-28 09:51 UTC, Wei Wang
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 61630 master MERGED rollback: log.err doesn't exist. Use log.error 2016-08-02 15:47:57 UTC
oVirt gerrit 61856 ovirt-4.0 MERGED rollback: log.err doesn't exist. Use log.error 2016-08-02 15:48:11 UTC

Description Wei Wang 2016-07-28 09:49:49 UTC
Created attachment 1184975 [details]
ks file

Description of problem:
Failure reason is lost when inputting command "nodectl rollback " in Terminal.

Version-Release number of selected component (if applicable):
redhat-virtualization-host-4.0-20160727.1.x86_64
imgbased-0.7.3-0.1.el7ev.noarch
cockpit-0.114-2.el7.x86_64
cockpit-ovirt-dashboard-0.10.6-1.3.3.el7ev.noarch


How reproducible:
100%
Not Regression bug
Keywords: UI

Steps to Reproduce:
1. Install redhat-virtualization-host-4.0-20160727.1.x86_64 with kickstart file in attachment
2. Login cockpit website hostIP:9090 with root account
3. Select "Terminal" page
4. Input nodectl rollback
5. Check the result


Actual results:
Failure reason is lost when inputting command "nodectl rollback " in Terminal.
[root@dhcp-11-209 var]# nodectl rollback
Status: Failure
  Reason:


Expected results:
The failure reason should be given.


Additional info:

Comment 1 Wei Wang 2016-07-28 09:51:34 UTC
Created attachment 1184976 [details]
log files

Comment 2 Fabian Deutsch 2016-07-28 10:38:10 UTC
A few things to understand:

1. Was there a second image to roll back to?
2. Did the roll back succeed or fail?

Comment 3 Fabian Deutsch 2016-07-28 10:40:47 UTC
Trageting for 4.02 for now, assuming that the functionality is broken. We can move it out if we see that it's just a visual problem.

Comment 4 Fabian Deutsch 2016-07-28 11:18:02 UTC
Moving out to 4.0.4 because the workaround is easy: Use imgbase rollback.

Comment 5 Ryan Barry 2016-07-28 12:52:06 UTC
(In reply to Fabian Deutsch from comment #4)
> Moving out to 4.0.4 because the workaround is easy: Use imgbase rollback.

The error won't be shown well with "imgbase rollback" either, because the problem is a typo in imgbased...

Comment 6 Wei Wang 2016-08-08 07:01:37 UTC
Test Version
RHVH-7.2-20160804.0-RHVH-x86_64-dvd1.iso
imgbased-0.7.4-0.1.el7ev.noarch
cockpit-0.114-2.el7.x86_64
cockpit-ovirt-dashboard-0.10.6-1.3.4.el7ev.noarch

Test Steps
1. Install RHVH-7.2-20160804.0-RHVH-x86_64-dvd1.iso
2. Login cockpit website hostIP:9090 with root account
3. Select "Terminal" page
4. Input "nodectl rollback"
5. Check the result

Result:
[root@localhost ~]# nodectl rollback
Status: Failure
  Reason:
    It's required to have at least two layers available to execute rollback operation!


So the bug is fixed, change the status to VERIFIED.


Note You need to log in before you can comment on or make changes to this bug.