Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1361059 - [RFE] Implement hotplug for pxb devices
Summary: [RFE] Implement hotplug for pxb devices
Keywords:
Status: CLOSED DUPLICATE of bug 1529494
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.3
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: rc
: 7.4
Assignee: Marcel Apfelbaum
QA Contact: yduan
Jiri Herrmann
URL:
Whiteboard:
Depends On:
Blocks: 1408812
TreeView+ depends on / blocked
 
Reported: 2016-07-28 09:34 UTC by yangyang
Modified: 2018-04-26 13:13 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
Devices attached to PXB/PXB-PCIe bridges can't be hot-plugged.
Clone Of:
: 1408812 (view as bug list)
Environment:
Last Closed: 2018-04-26 13:13:54 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1377160 None CLOSED [RFE] Q35: Implement hotplug for pxb-pcie devices 2019-03-08 01:51:15 UTC

Internal Links: 1377160

Description yangyang 2016-07-28 09:34:00 UTC
Description of problem:
If I hot-plug device into pxb by using libvirt, it reports 'device attach successfully'. However, the device can not be detected unless rebooting guest. So qemu does not support hotplug for pxb yet. 

Version-Release number of selected component (if applicable):
qemu-kvm-rhev-2.6.0-15.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Marcel Apfelbaum 2018-04-26 13:13:54 UTC

*** This bug has been marked as a duplicate of bug 1529494 ***


Note You need to log in before you can comment on or make changes to this bug.