Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1361047 - ipa-replica-install --help usage line suggests the replica file is needed
Summary: ipa-replica-install --help usage line suggests the replica file is needed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Kaleem
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-28 09:13 UTC by Jan Pazdziora
Modified: 2016-11-04 05:59 UTC (History)
4 users (show)

Fixed In Version: ipa-4.4.0-6.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 05:59:28 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Jan Pazdziora 2016-07-28 09:13:26 UTC
Description of problem:

When ipa-replica-install fails because of parameter mismatch or when ipa-replica-install --help is run, the Usage line lists REPLICA_FILE.

Version-Release number of selected component (if applicable):

ipa-server-4.4.0-3.el7.x86_64

How reproducible:

Deterministic.

Steps to Reproduce:
1. ipa-replica-install --help
2.
3.

Actual results:

# ipa-replica-install --help
Usage: ipa-replica-install [options] REPLICA_FILE

Options:
  --version             show program's version number and exit
  -h, --help            show this help message and exit
  -U, --unattended      unattended (un)installation never prompts the user
[...]

Expected results:

# ipa-replica-install --help
Usage: ipa-replica-install [options] [REPLICA_FILE]

Options:
  --version             show program's version number and exit
  -h, --help            show this help message and exit
  -U, --unattended      unattended (un)installation never prompts the user
[...]

Additional info:

Comment 2 Petr Vobornik 2016-08-03 11:20:12 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/6164

Comment 3 Martin Bašti 2016-08-05 10:10:11 UTC
Fixed upstream
master:
https://fedorahosted.org/freeipa/changeset/d8fe5863d297b74efff9ba6bbb2e8134e457d6e4

Comment 5 Xiyang Dong 2016-09-18 13:34:42 UTC
Verified on ipa-server-4.4.0-9.el7:

REPLICA_FILE is now optional.
[root@auto-hv-01-guest02 ~]# ipa-replica-install --help | grep Usage
Usage: ipa-replica-install [options] [REPLICA_FILE]

Comment 7 errata-xmlrpc 2016-11-04 05:59:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.