Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1361010 - [UI] - It's not possible to uncheck the 'Clone' checkbox in the Import VM/Import template dialog even when changing the existing names
Summary: [UI] - It's not possible to uncheck the 'Clone' checkbox in the Import VM/Imp...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage
Version: 4.0.0
Hardware: x86_64
OS: Linux
unspecified
medium vote
Target Milestone: ovirt-4.1.1
: ---
Assignee: Tal Nisan
QA Contact: Raz Tamir
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-28 06:52 UTC by Michael Burman
Modified: 2017-02-07 15:39 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-07 15:39:09 UTC
oVirt Team: Storage
tnisan: ovirt-4.1?
mburman: planning_ack?
mburman: devel_ack?
mburman: testing_ack?


Attachments (Terms of Use)
record (deleted)
2016-07-28 06:52 UTC, Michael Burman
no flags Details

Description Michael Burman 2016-07-28 06:52:37 UTC
Created attachment 1184892 [details]
record

Description of problem:
[UI] - It's not possible to uncheck the 'Clone' checkbox in the Import VM/Import template dialog even when changing the existing names.

When we trying to import VM/template with names that already exist in our environment the 'Clone' checkbox is checked by default and there is no way to uncheck it. We forced to import the VM/template as cloned ones. 
It seems like changing the names on the import dialog isn't making any difference and engine remember the IDs.  

Version-Release number of selected component (if applicable):
4.0.2-0.1.rc.el7ev

How reproducible:
100

Steps to Reproduce:
VM:
1. engine 4.0 and export domain
2. Create vm 'vm1' and export it to your export domain 
3. Import 'vm1' from you r export domiain. The 'Clone' checkbox is checked and grayed out and An exclamation mark will appear and warn that the VM name is already exist and we need to rename it.
4. After renaming the name of the vm, the vm will be exported as cloned, because we can't uncheck the the 'Clone' checkbox.  

Template:
1. engine 4.0 and export domain
2. Create vm 'vm1' and make a template from it 'temp1'
3. export 'temp1' to your export domain
4. Import 'temp1' from your export domain. The 'Clone' checkbox is checked and grayed out. When pressing 'OK' we are forced to import the template as cloned but required to change the name. 

Actual results:
In both cases we import vm and template as cloned, although we didn't want it.

Expected results:
Once changing the name of the vm or template we should have the option to uncheck the 'Clone' checkbox.

Comment 1 Yaniv Lavi 2017-02-07 15:39:09 UTC
Please use import storage domain feature which will resolve this issue.


Note You need to log in before you can comment on or make changes to this bug.