Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1361003 - dnf.plugin.copr (copr.py) cls.config_chroot returns None (affects setting dist in /etc/dnf/plugins/copr.conf)
Summary: dnf.plugin.copr (copr.py) cls.config_chroot returns None (affects setting dis...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf-plugins-core
Version: 24
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-28 06:36 UTC by Mike Goodwin
Modified: 2019-04-07 01:30 UTC (History)
9 users (show)

Fixed In Version: dnf-plugins-core-0.1.21-3.fc24 dnf-plugins-core-0.1.21-3.fc23 dnf-plugins-core-0.1.21-4.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-19 19:52:17 UTC


Attachments (Terms of Use)
Patch to fix chroot_config from being ignored (deleted)
2016-07-28 06:36 UTC, Mike Goodwin
no flags Details | Diff

Description Mike Goodwin 2016-07-28 06:36:08 UTC
Created attachment 1184884 [details]
Patch to fix chroot_config from being ignored

Description of problem:

COPR doesn't find any repos unless the distribution and releasever match properly, thus there was a feature added to manually set these values in /etc/dnf/plugins/copr.conf. 

This is currently broken, in the sense that those settings are not respected, other distributions rely on the these settings. 

Dists that rely on setting "Fedora" in this configuration file are unable to use COPR at this time.

Version-Release number of selected component (if applicable):

python3-dnf-plugins-core-0.1.21-2.fc24.noarch

How reproducible:

Always, python script isn't functioning properly 

Steps to Reproduce:
1. Use Korora 24
2. Attempt to enable a COPR repository 
3. Fails with: Error: This repository does not have any builds yet so you cannot enable it now. 

Actual results:

Error: This repository does not have any builds yet so you cannot enable it now. 

Expected results:

Settings from /etc/dnf/plugins/copr.conf are respected during dnf copr enable

Additional info:

Patch is included. I have no idea why this works, but figured it out through many hours of trial and error and pdb. I am not a python programmer, I just want to nudge someone to fix this (maybe more properly?). What's in the patch currently does work as intended against the indicated version, however.

Comment 1 Mike Goodwin 2016-07-28 20:24:10 UTC
New PR against correct branch dnf-1.1: https://github.com/rpm-software-management/dnf-plugins-core/pull/189

Comment 2 Fedora Update System 2016-08-18 15:22:17 UTC
dnf-1.1.10-1.fc24 dnf-plugins-core-0.1.21-3.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-878284e0d3

Comment 3 Fedora Update System 2016-08-18 15:22:26 UTC
dnf-1.1.10-1.fc23 dnf-plugins-core-0.1.21-3.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-267f843cda

Comment 4 Fedora Update System 2016-08-18 15:22:32 UTC
dnf-1.1.10-1.fc25 dnf-plugins-core-0.1.21-4.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-8caa619a9e

Comment 5 Fedora Update System 2016-08-18 15:22:38 UTC
dnf-1.1.10-1.fc24 dnf-plugins-core-0.1.21-3.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-878284e0d3

Comment 6 Fedora Update System 2016-08-18 16:53:27 UTC
dnf-1.1.10-1.fc25, dnf-plugins-core-0.1.21-4.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-8caa619a9e

Comment 7 Fedora Update System 2016-08-19 00:23:09 UTC
dnf-1.1.10-1.fc23, dnf-plugins-core-0.1.21-3.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-267f843cda

Comment 8 Fedora Update System 2016-08-19 00:58:19 UTC
dnf-1.1.10-1.fc24, dnf-plugins-core-0.1.21-3.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-878284e0d3

Comment 9 Fedora Update System 2016-08-19 19:51:15 UTC
dnf-1.1.10-1.fc24, dnf-plugins-core-0.1.21-3.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2016-08-23 15:20:24 UTC
dnf-1.1.10-1.fc23, dnf-plugins-core-0.1.21-3.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2016-08-27 10:21:29 UTC
dnf-1.1.10-1.fc25, dnf-plugins-core-0.1.21-4.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 RafaelRS 2019-04-07 01:30:20 UTC
Experiencing same in Fedora 29


Note You need to log in before you can comment on or make changes to this bug.