Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1361001 - Recursion in policies tree
Summary: Recursion in policies tree
Keywords:
Status: CLOSED DUPLICATE of bug 1361091
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.6.0
Hardware: All
OS: All
high
high
Target Milestone: GA
: 5.7.0
Assignee: Beni Paskin-Cherniavsky
QA Contact: Dafna Ron
URL:
Whiteboard: control:container:ui
Depends On:
Blocks: 1361215
TreeView+ depends on / blocked
 
Reported: 2016-07-28 06:34 UTC by Dmitry Misharov
Modified: 2016-07-31 08:48 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1361215 (view as bug list)
Environment:
Last Closed: 2016-07-31 08:48:21 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)
Screenshot of the bug (deleted)
2016-07-28 06:34 UTC, Dmitry Misharov
no flags Details

Description Dmitry Misharov 2016-07-28 06:34:12 UTC
Created attachment 1184882 [details]
Screenshot of the bug

Description of problem:
Container Image policies trees (control and compliance) expand endlessly.

Version-Release number of selected component (if applicable):
5.6.1.0.20160726144018_810a94f

How reproducible:
Always

Steps to Reproduce:
1. Navigate to Control->Explorer
2. Open Policies accordion
3. Expand Container Image Compliance Policies in Control or Compliance policies

Actual results:
There is another tree with the same policies.

Expected results:
There should be only Container Image policies

Comment 2 Dmitry Misharov 2016-07-28 06:38:15 UTC
The bug can be reproduced if no policies was added before.

Comment 3 Federico Simoncelli 2016-07-28 13:53:29 UTC
Beni can you look into this? Thanks.

Comment 5 Beni Paskin-Cherniavsky 2016-07-31 08:48:21 UTC
Dup.  Already fixed on master by
https://github.com/ManageIQ/manageiq/pull/10110
and on darga by
https://github.com/ManageIQ/manageiq/pull/10116

*** This bug has been marked as a duplicate of bug 1361091 ***


Note You need to log in before you can comment on or make changes to this bug.