Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1360985 - [SNAPSHOT]: The PID for snapd is displayed even after snapd process is killed.
Summary: [SNAPSHOT]: The PID for snapd is displayed even after snapd process is killed.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: snapshot
Version: 3.8.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Avra Sengupta
QA Contact:
URL:
Whiteboard:
Depends On: 1358244
Blocks: 1360979
TreeView+ depends on / blocked
 
Reported: 2016-07-28 06:11 UTC by Avra Sengupta
Modified: 2016-08-12 09:48 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.8.2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1358244
Environment:
Last Closed: 2016-08-12 09:48:11 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Avra Sengupta 2016-07-28 06:11:37 UTC
+++ This bug was initially created as a clone of Bug #1358244 +++

Description of problem:
Even after snapd process is killed, it's older pid continues to be displayed. 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Vijay Bellur on 2016-07-22 02:14:41 EDT ---

REVIEW: http://review.gluster.org/14981 (snapshot/snapd: Don't dispay pid when snapd is offline) posted (#1) for review on master by Avra Sengupta (asengupt@redhat.com)

--- Additional comment from Vijay Bellur on 2016-07-22 22:45:46 EDT ---

REVIEW: http://review.gluster.org/14981 (snapshot/snapd: Don't display pid when snapd is offline) posted (#2) for review on master by Avra Sengupta (asengupt@redhat.com)

--- Additional comment from Vijay Bellur on 2016-07-26 03:55:22 EDT ---

REVIEW: http://review.gluster.org/14981 (snapshot/snapd: Don't display pid when snapd is offline) posted (#3) for review on master by Avra Sengupta (asengupt@redhat.com)

--- Additional comment from Vijay Bellur on 2016-07-27 18:07:26 EDT ---

COMMIT: http://review.gluster.org/14981 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit ec6925a379c7bee071df1638bc2751b266cee346
Author: Avra Sengupta <asengupt@redhat.com>
Date:   Fri Jul 22 11:40:32 2016 +0530

    snapshot/snapd: Don't display pid when snapd is offline
    
    We were previously reading the pidfile, and displaying
    the pid even if snapd daemon is not running. Now to fix
    it, we re-assign pid value to -1, if snapd is offline.
    
    Change-Id: I4baff8d489fe9380061c52aea006db90fa421cd7
    BUG: 1358244
    Signed-off-by: Avra Sengupta <asengupt@redhat.com>
    Reviewed-on: http://review.gluster.org/14981
    Tested-by: Vijay Bellur <vbellur@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>

Comment 1 Vijay Bellur 2016-07-28 06:13:06 UTC
REVIEW: http://review.gluster.org/15033 (snapshot/snapd: Don't display pid when snapd is offline) posted (#1) for review on release-3.8 by Avra Sengupta (asengupt@redhat.com)

Comment 2 Vijay Bellur 2016-08-02 06:19:05 UTC
COMMIT: http://review.gluster.org/15033 committed in release-3.8 by Rajesh Joseph (rjoseph@redhat.com) 
------
commit 69029a8e1d9ebc5150a0eeb2b3faa6481c409965
Author: Avra Sengupta <asengupt@redhat.com>
Date:   Fri Jul 22 11:40:32 2016 +0530

    snapshot/snapd: Don't display pid when snapd is offline
    
        Backport of http://review.gluster.org/#/c/14981/
    
    We were previously reading the pidfile, and displaying
    the pid even if snapd daemon is not running. Now to fix
    it, we re-assign pid value to -1, if snapd is offline.
    
    > Reviewed-on: http://review.gluster.org/14981
    > Tested-by: Vijay Bellur <vbellur@redhat.com>
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > Smoke: Gluster Build System <jenkins@build.gluster.org>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    > Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
    
    (cherry picked from commit ec6925a379c7bee071df1638bc2751b266cee346)
    
    Change-Id: I4baff8d489fe9380061c52aea006db90fa421cd7
    BUG: 1360985
    Signed-off-by: Avra Sengupta <asengupt@redhat.com>
    Reviewed-on: http://review.gluster.org/15033
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>

Comment 3 Niels de Vos 2016-08-12 09:48:11 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.2, please open a new bug report.

glusterfs-3.8.2 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/announce/2016-August/000058.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.