Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1360977 - [RFE] Display bus/controller/lunid information in the RHEV-M GUI.
Summary: [RFE] Display bus/controller/lunid information in the RHEV-M GUI.
Keywords:
Status: CLOSED DUPLICATE of bug 968435
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs
Version: 3.6.7
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Scott Herold
QA Contact: Gil Klein
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-28 05:54 UTC by Ulhas Surse
Modified: 2016-12-06 13:43 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-06 13:43:11 UTC
oVirt Team: Storage


Attachments (Terms of Use)

Description Ulhas Surse 2016-07-28 05:54:35 UTC
3. What is the nature and description of the request?
   Expected functionality within the RHEV 3.6 GUI for Windows administrators (VMware).

   Our Windows administrators would need the ability to map the scsi id (bus number, target id, and lun) seen in the Windows guest VM to the hard-disk provided by RHEV in order to know which disk to remove and/or increase in size.

   This is possible only by leveraging a virsh -r dumpxml command on the host running the VM, and then correlating the ID of the disk to the hard-disk from the datacenter(disks) view within RHEV. It is not easily available information that we are used to having available while looking at the edit settings view of a VM in VMware (see, Virtual Device Node) while looking at the detailed hard-disk information.

4. Why does the customer need this? (List the business requirements here)
   Our Windows administrators would need the ability to map the scsi id (bus number, target id, and lun) seen in the Windows guest VM to the hard-disk provided by RHEV in order to know which disk to remove and/or increase in size.

5. How would the customer like to achieve this? (List the functional requirements here)
   Display bus/controller/lunid information in the RHEV-M GUI.

6. For each functional requirement listed, specify how Red Hat and the customer can test to confirm the requirement is successfully implemented.
   Yes

7. Is there already an existing RFE upstream or in Red Hat Bugzilla?
   No

8. Does the customer have any specific time-line dependencies and which release would they like to target (i.e. RHEL5, RHEL6)?
   No

9. Is the sales team involved in this request and do they have any additional input?
   No

10. List any affected packages or components.
   Unknown 

11. Would the customer be able to assist in testing this functionality if implemented?
   Yes

Comment 2 Michal Skrivanek 2016-09-28 08:43:14 UTC
we have the disk mapping as seen by the guest via guest agent. Isn't that a better solution? It's supposedly exposed somewhere, Liron?

Comment 3 Liron Aravot 2016-09-29 13:07:34 UTC
Thanks Michael,
Ulhas - Unfortunately, RHV can report the device mapping for disks in the guest - but currently only for image disks.

We currently have that BZ to handle the case for LUN disks -
https://bugzilla.redhat.com/show_bug.cgi?id=957788

if this one is a duplicate - we can close it and attach the ticket to the original bug.
I'll also try to find out if there are updates on that issue.

thanks,
Liron.

Comment 4 Liron Aravot 2016-09-29 13:12:48 UTC
BTW - does the customer uses the LUNs as disks or a as part of a block storage domain?
if they use them as part of block storage domain, the created disks on the domain are disk images for which we do support reporting the device name within the guest - in that case their issue is already solved and is available through some of our APIs. It's not available on the web-ui.

Please report back what exactly is needed.

thanks,
Liron.

Comment 5 Liron Aravot 2016-09-29 13:16:48 UTC
REST-API used get that information for image disks:

GET request on /api/vms/{vm_id}/disks

You will the device name within the guest under <logical_name>.

Please note that the ovirt-guest-agent needs to be running on the guest.

Comment 6 Ulhas Surse 2016-10-02 02:41:50 UTC
Thanks for the update. Let me confirm the disk is either from Storage domain or a direct LUN.

Comment 8 Yaniv Lavi 2016-12-06 13:43:11 UTC

*** This bug has been marked as a duplicate of bug 968435 ***


Note You need to log in before you can comment on or make changes to this bug.