Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1360962 - cakephp-mysql-example template cannot work well
Summary: cakephp-mysql-example template cannot work well
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Templates
Version: 3.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Ben Parees
QA Contact: XiuJuan Wang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-28 03:08 UTC by Wang Haoran
Modified: 2016-08-01 02:38 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-01 02:38:09 UTC


Attachments (Terms of Use)

Description Wang Haoran 2016-07-28 03:08:36 UTC
Description of problem:
cakephp-mysql-example template cannot work well on 3.1 env, works on 3.2 env

Version-Release number of selected component (if applicable):
openshift v3.1.1.6-64-g80b61da
kubernetes v1.1.0-origin-1107-g4c8e6f4
etcd 2.1.2


How reproducible:
alwasy

Steps to Reproduce:
1.oc new-app cakephp-mysql-example
2.
3.

Actual results:
cakephp-mysql-example-1-build     0/1       Completed          0          12m
cakephp-mysql-example-1-deploy    1/1       Running            0          12m
cakephp-mysql-example-1-prehook   0/1       CrashLoopBackOff   8          12m
mysql-1-u8hup                     1/1       Running    

[root@host-8-172-97 ~]# oc logs -f cakephp-mysql-example-1-prehook

Generating database schema 'cake schema generate' ...
./migrate-database.sh: line 6: cake: command not found

Expected results:


Additional info:

Comment 1 Ben Parees 2016-07-28 14:50:08 UTC
Can you confirm which template you are using and which imagestreams (rhel or centos) are installed?

Comment 2 Ben Parees 2016-07-28 14:59:05 UTC
(For the error you are hitting, the version of OSE does not matter, so you appear to be using two different php images in your two environments, we need to understand which ones you're using in each and why)

Comment 3 Wang Haoran 2016-07-28 15:25:15 UTC
The bc in the template is using php:5.6 , and we are using the image:
brew-pulp-docker01.web.qa.ext.phx1.redhat.com:8888/rhscl/php-56-rhel7:latest

Comment 4 Ben Parees 2016-07-28 17:29:34 UTC
and you're using the same template and image in your 3.2 environment?

btw you should not be using brew-pulp-docker01.web.qa.ext.phx1.redhat.com yet, that is an experimental registry.  the correct images are still in:
brew-pulp-docker01.web.prod.ext.phx2.redhat.com:8888

however i have confirmed that the image in both registries works correctly for me.

Comment 5 Wang Haoran 2016-08-01 02:38:09 UTC
Hi, Ben, why we are using qa registry is because we are testing the image after convert  from the v1 schema to v2 schema . but I cannot reproduce it now , will close this.


Note You need to log in before you can comment on or make changes to this bug.