Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1360958 - [RFE]: Block storage for container storage
Summary: [RFE]: Block storage for container storage
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: core
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pranith Kumar K
QA Contact:
URL:
Whiteboard:
Depends On: 1360956
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-28 02:34 UTC by Pranith Kumar K
Modified: 2018-10-22 05:31 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1360956
Environment:
Last Closed: 2018-10-22 05:31:23 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Pranith Kumar K 2016-07-28 02:34:54 UTC
We need the capability to use file as a block storage for containers.

Initial action items under this include:
1) This involves doing functionality/performance testing with tcmu. 
2) Provide read-write once capability for the block storage.
3) Test the solution provided by Andy for resizing the block device.
4) Block snapshots.

Comment 2 Nigel Babu 2018-10-08 03:24:00 UTC
Hey Pranith, this looks like it's done. Do you want to do the honor of closing this?

Comment 3 Pranith Kumar K 2018-10-22 05:31:23 UTC
https://github.com/gluster/gluster-block is the project where this feature is tracked. Closing this RFE.


Note You need to log in before you can comment on or make changes to this bug.