Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1360941 - libint FTBFS on aarch64 epel7
Summary: libint FTBFS on aarch64 epel7
Keywords:
Status: CLOSED DUPLICATE of bug 1243559
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: binutils
Version: 7.2
Hardware: aarch64
OS: Linux
unspecified
unspecified
Target Milestone: rc
: 7.3
Assignee: Nick Clifton
QA Contact: qe-baseos-tools
URL:
Whiteboard:
Depends On:
Blocks: epel7aarch64
TreeView+ depends on / blocked
 
Reported: 2016-07-27 23:32 UTC by D. Marlin
Modified: 2016-07-28 20:37 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-28 20:37:49 UTC


Attachments (Terms of Use)

Description D. Marlin 2016-07-27 23:32:59 UTC
Description of problem:

libint fails to build from source for Fedora EPEL7 on RHELSA-7.2.


Version-Release number of selected component (if applicable):

libint-1.1.6-9.el7


How reproducible:

consistently


Steps to Reproduce:
1.  On a RHELSA-7.2 host:
    mock rebuild libint-1.1.6-9.el7.src.rpm
2.
3.

Actual results:

.libs/hrr1_build_nn.o: In function `hrr1_build_nn(double const*, double*, double*, double*, int)':
bint/src/hrr1_build_nn.cc:24:(.text+0x47078): relocation truncated to fit: R_AARCH64_CALL26 against symbol `_hrr1_build_nn_0(double const*, double*, double*, double*, int)' defined in .text section in .libs/hrr1_build_nn.o
/builddir/build/BUILD/libint-0e0ffa7887e74e6ab1fb07c89be55f776c733731/src/lib/libint/src/hrr1_build_nn.cc:25:(.text+0x47090): relocation truncated to fit: R_AARCH64_CALL26 against symbol `_hrr1_build_nn_1(double const*, double*, double*, double*, int)' defined in .text section in .libs/hrr1_build_nn.o
/builddir/build/BUILD/libint-0e0ffa7887e74e6ab1fb07c89be55f776c733731/src/lib/libint/src/hrr1_build_nn.cc:26:(.text+0x470a8): relocation truncated to fit: R_AARCH64_CALL26 against symbol `_hrr1_build_nn_2(double const*, double*, double*, double*, int)' defined in .text section in .libs/hrr1_build_nn.o
/builddir/build/BUILD/libint-0e0ffa7887e74e6ab1fb07c89be55f776c733731/src/lib/libint/src/hrr1_build_nn.cc:27:(.text+0x470c0): relocation truncated to fit: R_AARCH64_CALL26 against symbol `_hrr1_build_nn_3(double const*, double*, double*, double*, int)' defined in .text section in .libs/hrr1_build_nn.o
/builddir/build/BUILD/libint-0e0ffa7887e74e6ab1fb07c89be55f776c733731/src/lib/libint/src/hrr1_build_nn.cc:28:(.text+0x470d8): relocation truncated to fit: R_AARCH64_CALL26 against symbol `_hrr1_build_nn_4(double const*, double*, double*, double*, int)' defined in .text section in .libs/hrr1_build_nn.o
/builddir/build/BUILD/libint-0e0ffa7887e74e6ab1fb07c89be55f776c733731/src/lib/libint/src/hrr1_build_nn.cc:29:(.text+0x470f0): relocation truncated to fit: R_AARCH64_CALL26 against symbol `_hrr1_build_nn_5(double const*, double*, double*, double*, int)' defined in .text section in .libs/hrr1_build_nn.o
/builddir/build/BUILD/libint-0e0ffa7887e74e6ab1fb07c89be55f776c733731/src/lib/libint/src/hrr1_build_nn.cc:30:(.text+0x47108): relocation truncated to fit: R_AARCH64_CALL26 against symbol `_hrr1_build_nn_6(double const*, double*, double*, double*, int)' defined in .text section in .libs/hrr1_build_nn.o
/builddir/build/BUILD/libint-0e0ffa7887e74e6ab1fb07c89be55f776c733731/src/lib/libint/src/hrr1_build_nn.cc:31:(.text+0x47120): relocation truncated to fit: R_AARCH64_CALL26 against symbol `_hrr1_build_nn_7(double const*, double*, double*, double*, int)' defined in .text section in .libs/hrr1_build_nn.o
/builddir/build/BUILD/libint-0e0ffa7887e74e6ab1fb07c89be55f776c733731/src/lib/libint/src/hrr1_build_nn.cc:32:(.text+0x47138): relocation truncated to fit: R_AARCH64_CALL26 against symbol `_hrr1_build_nn_8(double const*, double*, double*, double*, int)' defined in .text section in .libs/hrr1_build_nn.o
/builddir/build/BUILD/libint-0e0ffa7887e74e6ab1fb07c89be55f776c733731/src/lib/libint/src/hrr1_build_nn.cc:33:(.text+0x47150): relocation truncated to fit: R_AARCH64_CALL26 against symbol `_hrr1_build_nn_9(double const*, double*, double*, double*, int)' defined in .text section in .libs/hrr1_build_nn.o
/builddir/build/BUILD/libint-0e0ffa7887e74e6ab1fb07c89be55f776c733731/src/lib/libint/src/hrr1_build_nn.cc:34:(.text+0x47168): additional relocation overflows omitted from the output
collect2: error: ld returned 1 exit status


Expected results:

builds without errors.


Additional info:

The same source version builds on AArch64 for Fedora 25:

  http://arm.koji.fedoraproject.org/koji/buildinfo?buildID=385961

Comment 3 Yaakov Selkowitz 2016-07-28 20:37:49 UTC

*** This bug has been marked as a duplicate of bug 1243559 ***


Note You need to log in before you can comment on or make changes to this bug.