Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1360925 - Self Hosted RHV Deployment with two hosts fails
Summary: Self Hosted RHV Deployment with two hosts fails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: Installation - RHEV
Version: 1.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ga
: 1.0
Assignee: Fabian von Feilitzsch
QA Contact: James Olin Oden
Dan Macpherson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-27 20:54 UTC by James Olin Oden
Modified: 2016-09-13 16:34 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-13 16:34:40 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1862 normal SHIPPED_LIVE Red Hat Quickstart Installer 1.0 2016-09-13 20:18:48 UTC

Description James Olin Oden 2016-07-27 20:54:39 UTC
Description of problem:
Was deploying RHV as self hosted and selected two hosts.    When I did this, eventually it failed why deploying the second RHV host.   The error on the UI was the mysterious:

====== Puppet run for host mac525400452438.b.b status reported as Error ======

So I went to the host listed and looked for puppet-agent entries in /var/log/messages.   This revealed:

Jul 27 18:47:56 mac525400452438 puppet-agent[3783]: (/Stage[main]/Ovirt::Self_hosted::Setup/Exec[hosted-engine-setup]/returns) [ INFO  ] Stage: Setup validation
Jul 27 18:47:56 mac525400452438 puppet-agent[3783]: (/Stage[main]/Ovirt::Self_hosted::Setup/Exec[hosted-engine-setup]/returns)           Please provide the address of this host.
Jul 27 18:47:56 mac525400452438 puppet-agent[3783]: (/Stage[main]/Ovirt::Self_hosted::Setup/Exec[hosted-engine-setup]/returns)           Note: The engine VM and all the other hosts should be able to correctly resolve it.
Jul 27 18:47:56 mac525400452438 puppet-agent[3783]: (/Stage[main]/Ovirt::Self_hosted::Setup/Exec[hosted-engine-setup]/returns)           Host address:  [mac525400452438.b.b]: [ ERROR ] Failed to execute stage 'Setup validation': End of file
Jul 27 18:47:56 mac525400452438 puppet-agent[3783]: (/Stage[main]/Ovirt::Self_hosted::Setup/Exec[hosted-engine-setup]/returns) [ INFO  ] Stage: Clean up
Jul 27 18:47:56 mac525400452438 puppet-agent[3783]: (/Stage[main]/Ovirt::Self_hosted::Setup/Exec[hosted-engine-setup]/returns) [ INFO  ] Generating answer file '/var/lib/ovirt-hosted-engine-setup/answers/answers-20160727184756.conf'
Jul 27 18:47:56 mac525400452438 puppet-agent[3783]: (/Stage[main]/Ovirt::Self_hosted::Setup/Exec[hosted-engine-setup]/returns) [ INFO  ] Stage: Pre-termination
Jul 27 18:47:56 mac525400452438 puppet-agent[3783]: (/Stage[main]/Ovirt::Self_hosted::Setup/Exec[hosted-engine-setup]/returns) [ INFO  ] Stage: Termination
Jul 27 18:47:56 mac525400452438 puppet-agent[3783]: (/Stage[main]/Ovirt::Self_hosted::Setup/Exec[hosted-engine-setup]/returns) [ ERROR ] Hosted Engine deployment failed: this system is not reliable, please check the issue, fix and redeploy
Jul 27 18:47:56 mac525400452438 puppet-agent[3783]: (/Stage[main]/Ovirt::Self_hosted::Setup/Exec[hosted-engine-setup]/returns)           Log file is located at /var/log/ovirt-hosted-engine-setup/ovirt-hosted-engine-setup-20160727184737-yfl1dz.log
Jul 27 18:47:56 mac525400452438 puppet-agent[3783]: hosted-engine --deploy --config-append=/etc/qci/answers returned 1 instead of one of [0]
Jul 27 18:47:56 mac525400452438 puppet-agent[3783]: (/Stage[main]/Ovirt::Self_hosted::Setup/Exec[hosted-engine-setup]/returns) change from notrun to 0 failed: hosted-engine --deploy --config-append=/etc/qci/answers returned 1 instead of one of [0]
Jul 27 18:47:56 mac525400452438 puppet-agent[3783]: (/Stage[main]/Ovirt::Self_hosted::Config/Notify[oVirt Configuration stage- Done]) Dependency Exec[hosted-engine-setup] has failures: true
Jul 27 18:47:56 mac525400452438 puppet-agent[3783]: (/Stage[main]/Ovirt::Self_hosted::Config/Notify[oVirt Configuration stage- Done]) Skipping because of failed dependencies

Still not enough information so I went to the specified log:

/var/log/ovirt-hosted-engine-setup/ovirt-hosted-engine-setup-20160727184737-yfl1dz.log

And found this:

2016-07-27 18:47:56 DEBUG otopi.plugins.otopi.dialog.human dialog.__logString:219 DIALOG:SEND                 Please provide the address of this host.
2016-07-27 18:47:56 DEBUG otopi.plugins.otopi.dialog.human dialog.__logString:219 DIALOG:SEND                 Note: The engine VM and all the other hosts should be able to correctly resolve it.
2016-07-27 18:47:56 DEBUG otopi.plugins.otopi.dialog.human dialog.__logString:219 DIALOG:SEND                 Host address:  [mac525400452438.b.b]:
2016-07-27 18:47:56 DEBUG otopi.context context._executeMethod:156 method exception
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/otopi/context.py", line 146, in _executeMethod
    method['method']()
  File "/usr/share/ovirt-hosted-engine-setup/scripts/../plugins/ovirt-hosted-engine-setup/network/bridge.py", line 358, in _get_hostname_additional_hosts
    allow_empty=False,
  File "/usr/lib/python2.7/site-packages/ovirt_setup_lib/hostname.py", line 454, in getHostname
    store=(True if envkey else False),
  File "/usr/lib/python2.7/site-packages/ovirt_setup_lib/dialog.py", line 103, in queryEnvKey
    default=default,
  File "/usr/share/otopi/plugins/otopi/dialog/human.py", line 174, in queryString
    value = self._readline(hidden=hidden)
  File "/usr/lib/python2.7/site-packages/otopi/dialog.py", line 263, in _readline
    raise IOError(_('End of file'))
IOError: End of file

At this point I engaged development and they had me look at he answers file on said host:

    [environment:default]
    OVEHOSTED_CORE/confirmSettings=bool:True
    OVEHOSTED_CORE/deployProceed=bool:True
    OVEHOSTED_CORE/screenProceed=bool:True
    OVEHOSTED_STORAGE/domainType=str:nfs3
     
    OVEHOSTED_VDSM/cpu=str:{{ cpu_model }}
     
    OVEHOSTED_NETWORK/firewallManager=str:iptables
    OVEHOSTED_NETWORK/gateway=str:192.168.175.1
     
    OVEHOSTED_STORAGE/storageDomainConnection=str:192.168.175.10:/var/lib/exports/self_hosted
    OVEHOSTED_STORAGE/storageDomainName=str:my_hosted_storage
    OVEHOSTED_ENGINE/appHostName=str:hosted_engine_2
    OVEHOSTED_ENGINE/adminPassword=str:changeme
     
     
    # Multiple hypervisor things
    OVEHOSTED_STORAGE/hostID=str:2
    OVEHOSTED_CORE/isAdditionalHost=bool:True

Version-Release number of selected component (if applicable):
QCI-1.0-RHEL-7-20160726.t.0

How reproducible:
I've only tried this once.   I suspect it is reproducible.

Steps to Reproduce:
1.  Do a self-hosted RHEV deployment with two hosts specified.

Actual results:
It fails in puppet deploying the 2nd host.

Expected results:
It not fail.

Comment 2 Fabian von Feilitzsch 2016-08-02 19:23:25 UTC
Note: multiple hypervisors may not work if you test with access_insights enabled, due to an unrelated issue still under investigation. 

https://gitlab.sat.lab.tlv.redhat.com/rhci/puppet-ovirt/merge_requests/30

Comment 3 James Olin Oden 2016-08-05 13:23:38 UTC
Verified with QCI-1.0-RHEL-7-20160801.t.2.   Had insights disabled as suggested.   Was running in a libvirt environment.

Comment 5 errata-xmlrpc 2016-09-13 16:34:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862


Note You need to log in before you can comment on or make changes to this bug.