Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1360900 - OpenShift unable to pull containerized components from secure private registry
Summary: OpenShift unable to pull containerized components from secure private registry
Keywords:
Status: CLOSED DUPLICATE of bug 1316341
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: RFE
Version: 3.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Jason DeTiberus
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-27 18:43 UTC by broskos
Modified: 2016-08-02 06:05 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-02 06:05:06 UTC


Attachments (Terms of Use)

Description broskos 2016-07-27 18:43:54 UTC
Description of problem:
OpenShift is unable to use a password secured private registry from containerized components like ose-pod, ose-deployer, etc

Version-Release number of selected component (if applicable):
3.x

How reproducible:
Always

Steps to Reproduce:
1. Perform a disconnected installation according to the online docs
2. After installation point docker to your secured private registry
3. create a secret with oc secrets new dockercfg
4. perform container deployment on node without a pre-cached copy of ose-pod

Actual results:
container deployment fails, ose-pod is never pulled from secure private registry

Expected results:
container deployment should succeed, pulling ose-pod and any other needed containerized components from secure private repository.

Additional info:

Comment 1 Johnny Liu 2016-08-02 06:03:16 UTC
Seem like this bug is duplicated with BZ#1316341.

Comment 2 Johnny Liu 2016-08-02 06:05:06 UTC

*** This bug has been marked as a duplicate of bug 1316341 ***


Note You need to log in before you can comment on or make changes to this bug.