Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1360884 - RHEV Engine minimum RAM requirement is too low
Summary: RHEV Engine minimum RAM requirement is too low
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: Installation - RHEV
Version: 1.0
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ga
: 1.0
Assignee: Jesus M. Rodriguez
QA Contact: bmorriso
Dan Macpherson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-27 17:25 UTC by Tasos Papaioannou
Modified: 2016-09-13 16:34 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-13 16:34:37 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1862 normal SHIPPED_LIVE Red Hat Quickstart Installer 1.0 2016-09-13 20:18:48 UTC

Description Tasos Papaioannou 2016-07-27 17:25:52 UTC
Description of problem:

When creating a new deployment with 'Red Hat Virtualization' selected, the displayed requirements include:

----
Red Hat Virtualization
Engine + Hypervisor

    2 hosts (1 for engine, 1 for hypervisor). Engine host requires 10 GB disk space, 2GB RAM, and 1 CPU. Hypervisor host requires 10 GB disk space, 12GB RAM, and 4 CPUs
----

If I try a deployment with an engine host with 2 GB RAM, however, I see oom-killer getting invoked during the deployment. Depending on the process that gets killed, the deployment may fail. E.g.,

1.) Deployment 1 failed because the ovirt-engine java process was killed:

Jul 27 01:13:52 mac525400f6d027 kernel: java invoked oom-killer: gfp_mask=0x280da, order=0, oom_adj=0, oom_score_adj=0

2.) Deployment 2 completed, but ovirt-websocket/ovirt-engine-reportsd was killed:

Jul 27 15:43:08 mac525400f6d027 kernel: ovirt-websocket invoked oom-killer: gfp_mask=0x201da, order=0, oom_adj=0, oom_score_adj=0
[...]
Jul 27 15:43:09 mac525400f6d027 2016-07-27 15:43:09,457 ovirt-engine-reportsd: ERROR run:532 Error: process terminated with status code -9

The RHEV/RHV Installation Guides all give 4GB as the minimum for the manager/engine, so I'm not sure where fusor's 2GB value came from. It should be updated to match the documented RHEV requirements.

Version-Release number of selected component (if applicable):

QCI-1.0-RHEL-7-20160726.t.0.

How reproducible:

100% 
Steps to Reproduce:
1.) Deploy RHEV Engine+Hypervisor with a RHEV Engine that has 2GB RAM.
2.) See oom-killer activity logged in the engine's /var/log/messages, and possible failed deployments depending on what process got killed.


Actual results:

Occasional failed deployments, oom-killer killing processes on the RHEV engine.

Expected results:

No failed deployments or oom-killer activity.

Additional info:

Comment 1 John Matthews 2016-08-01 18:25:33 UTC
WebUi needs to be updated for the requirements.
Currently says 2GB needs to be 4GB.

As to comment#0 I think this relates to our devel scripts.

Comment 3 Jesus M. Rodriguez 2016-08-01 21:16:35 UTC
https://github.com/fusor/fusor/pull/1115

Comment 4 John Matthews 2016-08-05 17:20:07 UTC
Will be in compose 8/5

Comment 5 bmorriso 2016-08-08 13:29:52 UTC
Verified in compose QCI-1.0-RHEL-7-20160806.t.0

From Requirements Text:

"2 hosts (1 for engine, 1 for hypervisor). Engine host requires 10 GB disk space, 4GB RAM, and 1 CPU. Hypervisor host requires 10 GB disk space, 12GB RAM, and 4 CPUs"

Comment 7 errata-xmlrpc 2016-09-13 16:34:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862


Note You need to log in before you can comment on or make changes to this bug.