Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1360873 - Some Keys of the Keyboard are not Recognized / Erratic / Repeat
Summary: Some Keys of the Keyboard are not Recognized / Erratic / Repeat
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 24
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-27 16:54 UTC by Arvind K. Shah
Modified: 2016-08-03 07:22 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-03 07:22:23 UTC


Attachments (Terms of Use)

Description Arvind K. Shah 2016-07-27 16:54:06 UTC
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:43.0) Gecko/20100101 Firefox/43.0
Build Identifier: 

Keys 1, 3, -. q, t, u, p, ] and j are either not recognized, when pressed, or repeat on their own in my fresh installation of the KDE spin of Fedora 24 on Acer Emachines 725 laptop with T4200 dual core processor and 2 Gb RAM and 101 keys generic keyboard. The installation ran smoothly from the USB drive and I could easily login to the KDE desktop. I had been running Fedora 11 on this machine for last so many years without any hitch.

The problem was noticed when I tried to run dnf and update the system through Konsole. I could not enter the command 'dnf install ...' in one go as t would either be not recognized or appear as tt / ttt / tttttt... . I set repeat off in System Settings / Input devices but that was no help. The problem was there in entering password too with the same keys. The numerals including 1 and 3 could be entered correctly after switching NumLock on and pressing them on the extended number pad.

I managed to upgrade KDE to 6.5 with no solution to the keys problem. I then installed Gnome desktop and changed the display manager to gdm and back to sddm, without any change in the keys behaviour in KDE and Gnome, both.

I used dnf again, trying to install wine. It downloaded fine but could not be installed due to transaction error with dual pocl rpms of 686 and x86_64 versions.

I now find that the listed keys are not being recognized at all. Repeat/NoRecognition was a problem while entering passwords but could be managed while entering command on the console with backspace. Long key presses are also not being recognized.

Reproducible: Always

Comment 1 Kevin Fenzi 2016-07-27 18:12:33 UTC
so, this issue persists in both kde and gnome desktops?

Does it happen at a text console/vty?

Are you sure the keyboard is working properly?

Comment 2 Arvind K. Shah 2016-07-29 15:34:49 UTC
(In reply to Kevin Fenzi from comment #1)
> so, this issue persists in both kde and gnome desktops?
> 
> Does it happen at a text console/vty?
> 
> Are you sure the keyboard is working properly?

Mail: Thu, Jul 28, 2016 at 10:14 AM
Yes, it is so at the text console, in KDE and Gnome both.

The same problem is with Kwrite.

In KDE I have checked, when I go to System Settings - Input Devices -
Keyboard and test the keys - the reported keys malfunction.

Yes, the keyboard is fine. It worked well with Fedora11 installed for
years and the laptop is still a dual boot one with XP installed and
working perfectly.

Regards,
Arvind

Mail: Thu, Jul 28, 2016 at 9:01 PM
The Security and Applications logs have these entries, corresponding
to the mentioned keys, when pressed, I guess by their timing.

QXcb Connection: XCB error: 3 (BadWindow), sequence: 23721, resource
id: 10485760, major code: 18 (Change Property), minor code: 0

Only the Sequence and the resource id change for the key-presses.

Regards,

Mail: Fri, Jul 29, 2016 at 11:48 AM
Since the keys 1,3,-,q,t,u,p,] and j have stopped working altogether,
nothing erratic about them and no repetition, I did Ctrl+Alt+F3 to
kill the desktop and start text console and found that these keys are
not recognised at the login prompt also.

I did a reboot and started with XP and found that the same keys are
not working there too.

Does this confirm a hardware problem ?

Regards,

Arvind K. Shah

Comment 3 Kevin Fenzi 2016-07-29 18:43:22 UTC
What does: 

localectl

output?

Also, if you boot from a Fedora live media, does the problem occur there?

Comment 4 Arvind K. Shah 2016-07-30 15:16:07 UTC
1. localectl output:

System Locale: LANG=en_US.UTF-8
VC Keymap: us
X11 Layout: us

2. Yes, upon booting from USB, I landed into Local User Desktop and found the same problem with the reported keys in Konsole. I did Ctrl+Alt+F3 to get to the text console and the same keys are not recognized, there also.

Regards,

Comment 5 Kevin Fenzi 2016-07-31 16:54:53 UTC
Well, I am unsure what could cause this. Perhaps it's a issue with the kernel keyboard drivers? 

Moving over to kernel folks for comment or ideas...

Comment 6 Arvind K. Shah 2016-08-01 15:58:56 UTC
I am getting a new keyboard to replace the existing one and expect to reach a solution - shall be reporting here at the earliest.

Regards

Comment 7 Arvind K. Shah 2016-08-02 15:24:36 UTC
The new keyboard in my laptop has solved the problem. All the keys are working fine in KDE and Gnome both, as usual.

The machine was running Fedora11 for the last six-seven years and this problem cropped up just after a fresh installation of Fedora24, some ten days back.

I am embarased for having raised this issue. I have never faced anything like this ever since I started using RedHat 6.0, some twenty years back, on a Cyrix Pentium machine. The OS and the machines have come a long way since then and the continued use of old hardware and software, sufficient for my purpose, is a boon for me.

I am thankful to everybody for helping me reach a solution.

Best Regards,

Arvind K. Shah

Comment 8 Kevin Fenzi 2016-08-03 07:22:23 UTC
Great. Glad it's working now... and no problem, glad we could assist.


Note You need to log in before you can comment on or make changes to this bug.