Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1360823 - Showmount not showing symlinks in /etc/exports
Summary: Showmount not showing symlinks in /etc/exports
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: nfs-utils
Version: 23
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Steve Dickson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-27 15:05 UTC by Sean V. Thompson
Modified: 2016-08-27 16:07 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-27 16:07:23 UTC


Attachments (Terms of Use)

Description Sean V. Thompson 2016-07-27 15:05:24 UTC
Description of problem:
I created a set of symlinks to have "pretty" nfs share names. My /etc/exports directory has only the symlinks listed. I can externally mount the shares using the pretty names. However, when I do a "showmount -e" on my system, and remotely, it only shows the resolved symlink "TARGET".

Version-Release number of selected component (if applicable):
nfs-utils-1:1.3.3-8.rc5.fc23.x86_64 

How reproducible:
Always

Steps to Reproduce:
1. create a symlink "ln -s /mnt/share nfsshare"
2. add it to /etc/exports "/tmp/nfsshare *(rw)"
3. reload exports in to nfs "exportfs -r"
4. showmount -e 

Actual results:
/mnt/share *(rw)

Expected results:
/tmp/nfsshare *(rw)

Additional info:
N/a

Comment 1 Sean V. Thompson 2016-07-27 15:11:04 UTC
Step 0: Mount a drive/share/etc to /mnt/share

Comment 2 Steve Dickson 2016-08-27 16:07:23 UTC
This is by design... symlinks are resolved so the actual directory is export not the symlink. Do a exportfs -arv and you'll see /mnt/share is being exported not 
/tmp/nfsshare


Note You need to log in before you can comment on or make changes to this bug.