Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1360809 - [RFE] Capture events in GlusterD
Summary: [RFE] Capture events in GlusterD
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Atin Mukherjee
QA Contact:
URL:
Whiteboard:
Depends On: 1360807
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-27 14:20 UTC by Atin Mukherjee
Modified: 2017-03-27 18:19 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.9.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1360807
Environment:
Last Closed: 2017-03-27 18:19:27 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Atin Mukherjee 2016-07-27 14:20:01 UTC
+++ This bug was initially created as a clone of Bug #1360807 +++

Description of problem:

This RFE is to track the changes required in the glusterd component to capture all the async events which are required for eventing framework to consume them.

Comment 1 Vijay Bellur 2016-07-27 14:23:13 UTC
REVIEW: http://review.gluster.org/15015 (glusterd: Add async events) posted (#2) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 2 Vijay Bellur 2016-08-04 14:25:52 UTC
REVIEW: http://review.gluster.org/15015 (glusterd: Add async events) posted (#3) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 3 Vijay Bellur 2016-08-08 13:42:20 UTC
REVIEW: http://review.gluster.org/15015 (glusterd: Add async events) posted (#4) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 4 Vijay Bellur 2016-08-12 04:59:40 UTC
REVIEW: http://review.gluster.org/15153 (glusterd: add async events (part 2)) posted (#1) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 5 Vijay Bellur 2016-08-12 05:11:09 UTC
REVIEW: http://review.gluster.org/15015 (glusterd: Add async events) posted (#5) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 6 Vijay Bellur 2016-08-21 15:38:40 UTC
REVIEW: http://review.gluster.org/15015 (glusterd: Add async events) posted (#6) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 7 Vijay Bellur 2016-08-21 15:44:08 UTC
REVIEW: http://review.gluster.org/15153 (glusterd: add async events (part 2)) posted (#2) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 8 Worker Ant 2016-08-22 04:05:05 UTC
REVIEW: http://review.gluster.org/15015 (glusterd: Add async events) posted (#7) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 9 Worker Ant 2016-08-22 04:10:33 UTC
REVIEW: http://review.gluster.org/15153 (glusterd: add async events (part 2)) posted (#3) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 10 Worker Ant 2016-08-22 13:10:47 UTC
COMMIT: http://review.gluster.org/15015 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit ca18f4bccd090e98ee5342ca05d3c0f9f94e9e2c
Author: Atin Mukherjee <amukherj@redhat.com>
Date:   Tue Jul 26 16:01:56 2016 +0530

    glusterd: Add async events
    
    As the eventing framework is already in the code, this patch targets to capture
    all the async glusterd events which are important to be notified to the higher
    layers which consume the eventing framework.
    
    I plan to break this work into two different patches where this patch set covers
    the first set of events.
    
    Change-Id: Ie1bd4f6fa84117b26ccb4c75bc4dc68e6ef19134
    BUG: 1360809
    Signed-off-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-on: http://review.gluster.org/15015
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Rohan Kanade <rkanade@redhat.com>
    Reviewed-by: Samikshan Bairagya <samikshan@gmail.com>

Comment 11 Worker Ant 2016-08-22 13:25:18 UTC
REVIEW: http://review.gluster.org/15153 (glusterd: add async events (part 2)) posted (#4) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 12 Worker Ant 2016-08-23 05:15:46 UTC
REVIEW: http://review.gluster.org/15153 (glusterd: add async events (part 2)) posted (#5) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 13 Worker Ant 2016-08-23 14:48:05 UTC
COMMIT: http://review.gluster.org/15153 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit 063a234e6265265606425449da1d6c2f97fbf457
Author: Atin Mukherjee <amukherj@redhat.com>
Date:   Fri Aug 12 10:22:17 2016 +0530

    glusterd: add async events (part 2)
    
    Change-Id: I7a5687143713c283f0051aac2383f780e3e43646
    BUG: 1360809
    Signed-off-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-on: http://review.gluster.org/15153
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Samikshan Bairagya <samikshan@gmail.com>

Comment 14 Shyamsundar 2017-03-27 18:19:27 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.9.0, please open a new bug report.

glusterfs-3.9.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2016-November/029281.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.