Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1360797 - Please update to at least 2.0.7 release
Summary: Please update to at least 2.0.7 release
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: GitPython
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dennis Gilmore
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-27 13:55 UTC by Barry Scott
Modified: 2016-12-28 12:06 UTC (History)
6 users (show)

Fixed In Version: GitPython-2.1.1-1.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-28 12:06:47 UTC


Attachments (Terms of Use)

Description Barry Scott 2016-07-27 13:55:45 UTC
The F24 version of GitPython is 1.0.1 however the lastest release is 2.0.7.

There are many important fixes and improvements made since 1.0.1.

Please update to the latest.

Barry

Comment 1 Lubomír Sedlář 2016-08-19 07:20:04 UTC
Here's the issue:
 * GitPython dropped support for Python 2.6 in 2.0.0
 * rpkg (and inderectly fedpkg) depend on GitPython
 * rpkg upstream wants to support Python 2.6

If we update GitPython, we are quite likely breaking an important tool. If we don't, we're stuck with an old library.

I'm not sure what is the best way forward.

Comment 2 Barry Scott 2016-11-06 11:38:14 UTC
I do not understand your logic.

Given that python2.6 is not available on F24 what is the issue?

I hope you are not saying that rpkg only support python2.6, surely 2.7 is supported.

Barry

Comment 3 Lubomír Sedlář 2016-11-07 08:02:48 UTC
Rpkg upstream wants to support other systems than F24 that still support 2.6. It indeed does support 2.7 as well as being updated for Python 3. It just isn't ready to drop support for 2.6.

Comment 4 Barry Scott 2016-11-07 09:47:17 UTC
I think the claim of python 2.6 support is a not the key issue.
It is also not an issue that rpkg want to support old systems,
it is surely for them to figure out how to work across a range of
dependencies in that case.

The issue is this: will rpkg work with GitPython 2.x?

Do you know if rpkg break is GitPython 2.x is installed?

If it does then rpkg needs to fix any problems by doing a version
check against GitPython and use a two code paths.

When features where added to GitPython it was done with a lot of care
for backwards compatibility. I believe that the python2.6 support being
dropped was because of the desire to support python3.

Barry

Comment 5 Barry Scott 2016-11-18 14:59:40 UTC
Please update to latest GitPython as rpkg is not a blocker.

Please see email thread on Fedora Devel list especially the report of
all rpkg tests passing against GitPython 2 from Chenxiong Qi on 16 nov 2016.

"I've tested GitPython >= 2 with rpkg by running all existent tests, that covers most of the calls to GitPython API. All tests passed, and I don't see an issue. I'm glad to see the upgrade too. I think the upgrade should not be a big issue to rpkg, as there is still GitPython 1.x in EPEL6."

Barry

Comment 6 Ewoud Kohl van Wijngaarden 2016-12-08 10:24:40 UTC
I hope to package python-git-up and that needs GitPython >= 2.0.0. Resolving this would help me a lot.

Comment 7 Barry Scott 2016-12-09 17:47:48 UTC
Work has started on this.


Note You need to log in before you can comment on or make changes to this bug.