Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1360755 - tempest.api.identity.admin.v3.test_trusts.TrustsV3TestJSON.test_get_trusts_all missing domain attribute
Summary: tempest.api.identity.admin.v3.test_trusts.TrustsV3TestJSON.test_get_trusts_al...
Keywords:
Status: CLOSED DUPLICATE of bug 1366944
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tempest
Version: 8.0 (Liberty)
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Daniel Mellado
QA Contact: tkammer
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-27 12:13 UTC by August Simonelli
Modified: 2016-10-14 13:13 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-14 13:13:38 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description August Simonelli 2016-07-27 12:13:01 UTC
Description of problem:
running test tempest.api.identity.admin.v3.test_trusts.TrustsV3TestJSON.test_get_trusts_all fails with authorization denied.

Version-Release number of selected component (if applicable):
openstack-tempest-liberty-20160317.1.el7ost.noarch

How reproducible:
every time.

Steps to Reproduce:
1. source a v3-enabled rc file
2. run tools/run-tests.sh tempest.api.identity.admin.v3.test_trusts.TrustsV3TestJSON.test_get_trusts_all
3.

Actual results:
Fails but with an auth denied error:
    2016-07-27 08:11:15,576 23926 INFO     [tempest.lib.common.rest_client] Request (TrustsV3TestJSON:setUp): 401 GET http://172.31.10.96:5000/v3/users 0.040s
    2016-07-27 08:11:15,577 23926 DEBUG    [tempest.lib.common.rest_client] Request - Headers: {'Content-Type': 'application/json', 'Accept': 'application/json', 'X-Auth-Token': '<omitted>'}
            Body: None
        Response - Headers: {'status': '401', 'content-length': '114', 'vary': 'X-Auth-Token', 'www-authenticate': 'Keystone uri="https://clvcw1ov201.uae-dev.cmn-model.corp.telstra.com:13000"', 'connection': 'close', 'date': 'Wed, 27 Jul 2016 12:11:28 GMT', 'content-type': 'application/json', 'x-openstack-request-id': 'req-ce36422f-8099-4e0f-afe3-90f88b1d7fbb'}
            Body: {"error": {"message": "The request you have made requires authentication.", "code": 401, "title": "Unauthorized"}}

Expected results:
Pass (or fail) but based on the test, not access to it.

Additional info:

Keystone logs show
2016-07-27 21:08:48.685 6330 WARNING keystone.common.wsgi [req-b8ba511e-102f-4347-8a08-25566f4b446e - - - - -] Authorization failed. The request you have made requires authentication. from 172.31.10.68
when runnnig the test.

Comment 2 August Simonelli 2016-07-27 12:14:53 UTC
We added the domain to tempest/api/identity/admin/v3/test_trusts.py and this allowed the test to run without the auth error, ie:

$ sudo diff tempest/api/identity/admin/v3/test_trusts.py tempest/api/identity/admin/v3/test_trusts.py.orig
91c91
<         self.trustee_user_id = self.get_user_by_name(trustee_username,"Default")['id']
---
>         self.trustee_user_id = self.get_user_by_name(trustee_username)['id']

Comment 3 Daniel Mellado 2016-10-14 13:13:38 UTC

*** This bug has been marked as a duplicate of bug 1366944 ***


Note You need to log in before you can comment on or make changes to this bug.