Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1360670 - Add output option `--xml` to man page of gluster
Summary: Add output option `--xml` to man page of gluster
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: cli
Version: mainline
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
Assignee: Mohit Agrawal
QA Contact:
URL:
Whiteboard:
Depends On: 1362025
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-27 09:36 UTC by Mohit Agrawal
Modified: 2017-03-06 17:21 UTC (History)
16 users (show)

Fixed In Version: glusterfs-3.10.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1109173
Environment:
Last Closed: 2017-03-06 17:21:32 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Mohit Agrawal 2016-07-27 09:36:52 UTC
+++ This bug was initially created as a clone of Bug #1109173 +++

Description of problem
======================

GlusterFS command line tool `glusterfs` has (so far) undocumented output
option `--xml` which servers as a stable machine readable output format.
Unless we have really good reason to keep this secret, we should consider
to document this feature properly.

Moreover Storage QE seems to already use this feature.

Version-Release number of selected component (if applicable)
============================================================

Red Hat Storage 3 Administration Guide (from documentation-devel)
glusterfs man pages (glusterfs-3.6.0.11-1.el6rhs.x86_64)

--- Additional comment from Stanislav Graf on 2014-08-12 10:20:55 EDT ---

Setting 3.1 instead of generic rhs-future as a proposal for acks, resetting acks. I think QE would be OK to move it also to 3.0.1 if there will be time for it.

--- Additional comment from Nagaprasad Sathyanarayana on 2015-03-26 08:30:46 EDT ---

After having triaged, it was agreed by all leads that this BZ can not be fixed for 3.1.0 release.

--- Additional comment from Anjana Suparna Sriram on 2015-08-11 05:15:29 EDT ---

Hi Martin,

Are you suggesting that a new man page needs to be created or the Admin Guide needs to be updated?

--- Additional comment from Martin Bukatovic on 2015-08-11 05:35:03 EDT ---

I think that updating man page gluster(8) (so that --xml flag is described) is
a must have. And since this feature could be easily missed, it would also make
sense to mention it in the Admin Guide - short note would be enough.

Also I noticed I made a mistake in the description of this BZ, the cli tool is
`gluster` and so related man page is gluster.8.gz from glusterfs-cli package.

--- Additional comment from Red Hat Bugzilla Rules Engine on 2015-09-09 04:35:32 EDT ---

Since this bug does not have release flag 'rhgs-3.1.z+', the Target Release is being automatically reset to '---'

--- Additional comment from Rejy M Cyriac on 2015-09-11 03:51:04 EDT ---

Changed component as per observation recorded at Comment 4

--- Additional comment from Anjana Suparna Sriram on 2016-01-14 03:04:16 EST ---

Kaushal,

This bug does not pertain to documentation. Please review Comment 4.

Regards,
Anjana

--- Additional comment from Kaushal on 2016-01-18 04:42:31 EST ---

We need a separate component for man-pages, which are technically documentation. Since there isn't such a component now, I'd moved this to 'Documentation', which I assumed was for all general documentation bugs, not covered under the other 'doc_*' components.

--- Additional comment from Rejy M Cyriac on 2016-01-18 04:51:22 EST ---

(In reply to Kaushal from comment #8)
> We need a separate component for man-pages, which are technically
> documentation. Since there isn't such a component now, I'd moved this to
> 'Documentation', which I assumed was for all general documentation bugs, not
> covered under the other 'doc_*' components.

As per policy, the downstream components are based on package names, and so unless we have a downstream package for man-pages, the bugs on man-pages have to use the same component as for the package in which it is shipped. At the component, we could have separate sub-component for the man-pages if required though.

--- Additional comment from Laura Bailey on 2016-03-03 19:54:42 EST ---

Rejy, does comment 9 mean this should be moved to the glusterfs component?

--- Additional comment from Rejy M Cyriac on 2016-03-04 07:09:41 EST ---

(In reply to Laura Bailey from comment #10)
> Rejy, does comment 9 mean this should be moved to the glusterfs component?

That is what I believe to be the right one. I have set it to that component.

Atin,

This is a pretty old bug. Is the issue still valid ? If so, being a 'man' page fix, I suspect it could be done easily.

Could this be fixed for RHGS 3.1.3 ?

Comment 1 Vijay Bellur 2016-07-27 10:04:56 UTC
REVIEW: http://review.gluster.org/15027 (gluster/cli Add output option "--xml" to man page of gluster) posted (#1) for review on master by MOHIT AGRAWAL (moagrawa@redhat.com)

Comment 2 Vijay Bellur 2016-07-28 08:36:42 UTC
REVIEW: http://review.gluster.org/15027 (gluster man page: Add output option "--xml" to man page of gluster) posted (#2) for review on master by MOHIT AGRAWAL (moagrawa@redhat.com)

Comment 3 Vijay Bellur 2016-07-29 19:33:04 UTC
COMMIT: http://review.gluster.org/15027 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 138bea7ea65987ca23f73c1f0c4f8868fd38cdff
Author: Mohit Agrawal <moagrawa@redhat.com>
Date:   Wed Jul 27 15:32:56 2016 +0530

    gluster man page: Add output option "--xml" to man page of gluster
    
    BUG: 1360670
    Change-Id: Ia167bb5b541a12459f70ab1205bd4ffdab8c7e65
    Signed-off-by: Mohit Agrawal <moagrawa@redhat.com>
    Reviewed-on: http://review.gluster.org/15027
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

Comment 4 Worker Ant 2016-12-15 15:59:39 UTC
REVIEW: http://review.gluster.org/16142 (doc: fix gluster man page) posted (#1) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 5 Worker Ant 2016-12-15 18:26:55 UTC
COMMIT: http://review.gluster.org/16142 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit c6fdc2f819b265e018d858232293407835fe2c6c
Author: Atin Mukherjee <amukherj@redhat.com>
Date:   Thu Dec 15 21:27:21 2016 +0530

    doc: fix gluster man page
    
    gluster --xml will take into the interactive prompt which is not an
    intended message here.
    
    Change-Id: Iea5b094a1b1b429d211008a3c7459b703c1a0a12
    BUG: 1360670
    Signed-off-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-on: http://review.gluster.org/16142
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

Comment 6 Worker Ant 2016-12-16 04:26:49 UTC
REVIEW: http://review.gluster.org/16157 (Revert "doc: fix gluster man page") posted (#1) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 7 Worker Ant 2016-12-16 04:46:23 UTC
COMMIT: http://review.gluster.org/16157 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit d2dff6320adc5c58ed8ed68dc1d3209149c29584
Author: Atin Mukherjee <amukherj@redhat.com>
Date:   Fri Dec 16 09:53:19 2016 +0530

    Revert "doc: fix gluster man page"
    
    This reverts commit c6fdc2f819b265e018d858232293407835fe2c6c.
    
    Initially I thought gluster --xml taking into the shell prompt is not a
    correct behavior, however if we execute any commands from that prompt we
    get xml output which is the original intention. This patch reverts the
    change and put back --xml option for gluster in man page.
    
    Change-Id: If77d0c0bf27f8cfc799973003c860d9bd8cd6407
    BUG: 1360670
    Signed-off-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-on: http://review.gluster.org/16157
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: MOHIT AGRAWAL <moagrawa@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.org>

Comment 8 Shyamsundar 2017-03-06 17:21:32 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.0, please open a new bug report.

glusterfs-3.10.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-February/030119.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.