Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1360650 - some application windows don't always refresh correctly
Summary: some application windows don't always refresh correctly
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: marco
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Wolfgang Ulbrich
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-27 08:59 UTC by Dominik 'Rathann' Mierzejewski
Modified: 2016-11-29 10:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-29 10:40:21 UTC


Attachments (Terms of Use)

Description Dominik 'Rathann' Mierzejewski 2016-07-27 08:59:04 UTC
Description of problem:
I've just upgraded to F24 from F23 and encountered this problem:

When typing in gnome-terminal or mate-terminal, usually no characters are displayed. In some cases, the first two or three are displayed. When I hit "Enter", suddenly they appear.

Version-Release number of selected component (if applicable):
$ rpm -q gnome-terminal mate-terminal vte291
gnome-terminal-3.20.2-2.fc24.x86_64
mate-terminal-1.14.0-2.fc24.x86_64
vte291-0.44.2-1.fc24.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Open gnome-terminal or mate-terminal, type something and press Enter.

Actual results:
No text appears until I hit Enter.

Expected results:
Typed characters should appear as they are typed.

Additional info:
lxterminal doesn't suffer from this bug. I'm filing this against vte291 as it's a common dependency of both gnome-terminal and mate-terminal, but I'm not sure where the bug is. lxterminal uses vte, not vte291.

This didn't happen in F23, where vte291 is at version 0.42.5-1.fc23. It could also be a bug in gtk3 (lxterminal uses gtk2), which was bumped from 3.18.9-1.fc23 to 3.20.6-1.fc24 during upgrade.

Comment 1 Dominik 'Rathann' Mierzejewski 2016-07-27 08:59:50 UTC
FWIW, this makes both gnome-terminal and mate-terminal rather unusable.

Comment 2 Egmont Koblinger 2016-07-27 09:15:25 UTC
Could be similar to https://bugzilla.gnome.org/show_bug.cgi?id=730763, or perhaps a video card driver problem.

Comment 3 Dominik 'Rathann' Mierzejewski 2016-07-27 11:16:37 UTC
Slightly similar, but it happens 100% of the time, with new windows, as well. Also, I don't see any CPU usage spikes. Any idea how to debug this?

Comment 4 Dominik 'Rathann' Mierzejewski 2016-07-27 12:41:59 UTC
FYI, I've just tried booting from a LiveUSB of MATE F24 spin and it doesn't happen there at all.

Comment 5 Dominik 'Rathann' Mierzejewski 2016-07-27 12:44:27 UTC
And it doesn't happen in another user's profile, so it's definitely something with my profile. :(

Comment 6 Dominik 'Rathann' Mierzejewski 2016-07-29 22:14:47 UTC
I found the trigger. My profile had compositing disabled in the window manager (marco). Enabling it makes the issue go away. Disabling compositing on another user's profile and launching a new terminal window reproduces the issue.

Comment 7 Dominik 'Rathann' Mierzejewski 2016-07-29 22:15:17 UTC
marco-1.14.2-1.fc24.x86_64

Comment 8 Dominik 'Rathann' Mierzejewski 2016-08-22 16:06:15 UTC
Ok, so that wasn't exactly the trigger. Enabling compositing makes the issue go away mostly, but not completely. With compositing enabled, I sometimes see the terminal window flipping between the current and previous screen content, for example without the last line. Ctrl+L refreshes the window properly, but the issue occurs again after some time.

Comment 9 Dominik 'Rathann' Mierzejewski 2016-11-19 23:11:16 UTC
Reassigning to marco as I've just reproduced it in Firefox while playing youtube videos with compositing enabled. Disabling compositing in marco helps with Firefox.

Comment 10 Dominik 'Rathann' Mierzejewski 2016-11-19 23:23:20 UTC
Also reproducible on F25 in firefox with any youtube video. The video frame is flipping between current frame and an older one, which makes it impossible to watch. As on F24, disabling compositing in marco makes it go away.

marco-1.16.0-1.fc25.x86_64
firefox-50.0-1.fc25.x86_64
gtk3-3.22.2-2.fc25.x86_64
mate-terminal-1.16.1-2.fc25.x86_64

Comment 11 Dominik 'Rathann' Mierzejewski 2016-11-29 10:40:21 UTC
Actually, the firefox issue was due to enabling some experimental hardware acceleration features enabled, so forget Firefox for now.

Also, I can't reproduce this anymore, either with or without compositing enabled, so closing. Sorry for the noise.


Note You need to log in before you can comment on or make changes to this bug.