Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1360579 - tests: ./tests/bitrot/br-stub.t fails intermittently
Summary: tests: ./tests/bitrot/br-stub.t fails intermittently
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tests
Version: 3.8.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kotresh HR
QA Contact:
URL:
Whiteboard:
Depends On: 1358114 1360578
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-27 05:44 UTC by Kotresh HR
Modified: 2016-08-12 09:48 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.8.2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1360578
Environment:
Last Closed: 2016-08-12 09:48:11 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Kotresh HR 2016-07-27 05:44:01 UTC
+++ This bug was initially created as a clone of Bug #1360578 +++

+++ This bug was initially created as a clone of Bug #1358114 +++

Description of problem:
./tests/bitrot/br-stub.t fails intermittently in regression.

Version-Release number of selected component (if applicable):
mainline

How reproducible:
Intermittently

Steps to Reproduce:
Regression run

Actual results:
./tests/bitrot/br-stub.t fails occasionally

Expected results:
./tests/bitrot/br-stub.t should always pass

Comment 1 Vijay Bellur 2016-07-27 05:44:58 UTC
REVIEW: http://review.gluster.org/15021 (tests: Fix spurious failure of br-stub.t) posted (#1) for review on release-3.8 by Kotresh HR (khiremat@redhat.com)

Comment 2 Vijay Bellur 2016-07-27 10:38:27 UTC
COMMIT: http://review.gluster.org/15021 committed in release-3.8 by Raghavendra Talur (rtalur@redhat.com) 
------
commit 0d52723332d06ec886273c7a9f01e058712b008c
Author: Kotresh HR <khiremat@redhat.com>
Date:   Wed Jul 20 11:36:31 2016 +0530

    tests: Fix spurious failure of br-stub.t
    
    Backport of http://review.gluster.org/14960/
    
    The nfs mount fails occasionally in ./tests/bitrot/br-stub.t.
    The reason being nfs mount is attempted before the gluster
    nfs has come up. It is a race and hence happens occasionally.
    The patch fixes it by waiting for nfs server to come up
    before mount.
    
    Thanks skoduri@redhat.com for root causing it.
    
    Change-Id: I3adbf2363514635785c02b1478733095ad0b74cf
    BUG: 1360579
    Signed-off-by: Kotresh HR <khiremat@redhat.com>
    (cherry picked from commit f4bbe515097e0149c78c1fc1bae9fb90928e7cd8)
    Reviewed-on: http://review.gluster.org/15021
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Raghavendra Talur <rtalur@redhat.com>

Comment 3 Niels de Vos 2016-08-12 09:48:11 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.2, please open a new bug report.

glusterfs-3.8.2 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/announce/2016-August/000058.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.