Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1360575 - Fix spurious failures in ec.t
Summary: Fix spurious failures in ec.t
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tests
Version: 3.8.1
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
Assignee: Pranith Kumar K
QA Contact:
URL:
Whiteboard:
Depends On: 1359001
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-27 05:16 UTC by Pranith Kumar K
Modified: 2016-08-12 09:48 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.8.2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1359001
Environment:
Last Closed: 2016-08-12 09:48:11 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Pranith Kumar K 2016-07-27 05:16:14 UTC
+++ This bug was initially created as a clone of Bug #1359001 +++

Description of problem:
    Problem:
    Because of timing issue sometimes the mount is unmounted
    even before the version is updated, this is leading to
    not triggering heals.
    
    Fix:
    One way to fix this would be to increate 'sleep 2' to 'sleep 10'
    but that would slow things down. I changed the way ec learns
    it needs xattr healing so that it triggers heals even when the
    xattrs are not marked correctly.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Vijay Bellur on 2016-07-22 00:59:51 EDT ---

REVIEW: http://review.gluster.org/14980 (tests: Fix timing issue in ec.t) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

--- Additional comment from Vijay Bellur on 2016-07-22 11:14:00 EDT ---

COMMIT: http://review.gluster.org/14980 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit 1c9b229a860908ffc0c0134450c9218bc8079c22
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Fri Jul 22 10:25:49 2016 +0530

    tests: Fix timing issue in ec.t
    
    Problem:
    Because of timing issue sometimes the mount is unmounted
    even before the version is updated, this is leading to
    not triggering heals.
    
    Fix:
    One way to fix this would be to increate 'sleep 2' to 'sleep 10'
    but that would slow things down. I changed the way ec learns
    it needs xattr healing so that it triggers heals even when the
    xattrs are not marked correctly.
    
    Change-Id: I1c82041166443ae7079dd99b89ea2ed170233ba3
    BUG: 1359001
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/14980
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>

Comment 1 Vijay Bellur 2016-07-27 05:53:01 UTC
REVIEW: http://review.gluster.org/15024 (tests: Fix timing issue in ec.t) posted (#1) for review on release-3.8 by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 2 Vijay Bellur 2016-07-27 14:29:08 UTC
COMMIT: http://review.gluster.org/15024 committed in release-3.8 by Niels de Vos (ndevos@redhat.com) 
------
commit 9112c896e7ad3087654a1bc8bc0d78c5effa885d
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Fri Jul 22 10:25:49 2016 +0530

    tests: Fix timing issue in ec.t
    
    Problem:
    Because of timing issue sometimes the mount is unmounted
    even before the version is updated, this is leading to
    not triggering heals.
    
    Fix:
    One way to fix this would be to increate 'sleep 2' to 'sleep 10'
    but that would slow things down. I changed the way ec learns
    it needs xattr healing so that it triggers heals even when the
    xattrs are not marked correctly.
    
     >Change-Id: I1c82041166443ae7079dd99b89ea2ed170233ba3
     >BUG: 1359001
     >Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
     >Reviewed-on: http://review.gluster.org/14980
     >Smoke: Gluster Build System <jenkins@build.gluster.org>
     >NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
     >CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
     >Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
    
    BUG: 1360575
    Change-Id: I3e7812e3b54caee651e20d4f5dd7dded2f2aa8d6
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/15024
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>

Comment 3 Niels de Vos 2016-08-12 09:48:11 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.2, please open a new bug report.

glusterfs-3.8.2 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/announce/2016-August/000058.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.