Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1360485 - PyQt4-webkit package required for Processing plugin but is not installed by DNF as dependency.
Summary: PyQt4-webkit package required for Processing plugin but is not installed by D...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: qgis
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Volker Fröhlich
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1362543 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-26 22:21 UTC by Evan
Modified: 2016-09-16 14:13 UTC (History)
6 users (show)

Fixed In Version: qgis-2.14.3-5.fc25 qgis-2.14.3-5.fc24
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-28 08:26:37 UTC


Attachments (Terms of Use)

Description Evan 2016-07-26 22:21:50 UTC
Description of problem:

The Processing plugin of QGIS 2.14 requires the PyQt4-webkit package installed in order to work, however PyQt4-webkit is not marked as a dependency for QGIS by DNF. Perhaps it is not because it is a plugin and not part of the core software, however it is a plugin that is installed and turned on by default and in this end-user's perspective definitely should be considered a necessary component of a full QGIS install.

See the bug listing on the QGIS forum:
https://hub.qgis.org/issues/15237

Version-Release number of selected component (if applicable):
QGIS 2.14.3-3

How reproducible:
100% on my machine

Steps to Reproduce:
1. dnf install qgis
2. attempt to open an instance of qgis

Actual results:

A window with an error message pops up before the QGIS instance is open that says:

Couldn't load plugin 'processing' 

ImportError: cannot import name QtWebKit 
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/qgis/utils.py", line 281, in loadPlugin
    __import__(packageName)
  File "/usr/lib64/python2.7/site-packages/qgis/utils.py", line 572, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
  File "/home/flo/.qgis2/python/plugins/processing/__init__.py", line 29, in 
    from processing.tools.general import *
  File "/usr/lib64/python2.7/site-packages/qgis/utils.py", line 572, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
  File "/home/flo/.qgis2/python/plugins/processing/tools/general.py", line 28, in 
    from processing.core.Processing import Processing
  File "/usr/lib64/python2.7/site-packages/qgis/utils.py", line 572, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
  File "/home/flo/.qgis2/python/plugins/processing/core/Processing.py", line 43, in 
    from processing.gui.Postprocessing import handleAlgorithmResults
  File "/usr/lib64/python2.7/site-packages/qgis/utils.py", line 572, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
  File "/home/flo/.qgis2/python/plugins/processing/gui/Postprocessing.py", line 36, in 
    from processing.gui.ResultsDialog import ResultsDialog
  File "/usr/lib64/python2.7/site-packages/qgis/utils.py", line 572, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
  File "/home/flo/.qgis2/python/plugins/processing/gui/ResultsDialog.py", line 38, in 
    os.path.join(pluginPath, 'ui', 'DlgResults.ui'))
  File "/usr/lib64/python2.7/site-packages/PyQt4/uic/__init__.py", line 211, in loadUiType
    exec(code_string.getvalue(), ui_globals)
  File "", line 52, in 
ImportError: cannot import name QtWebKit

Python version: 2.7.11 (default, Jun 21 2016, 09:15:12) [GCC 6.1.1 20160510 (Red Hat 6.1.1-2)] 
QGIS version: 2.14.3-Essen Essen, exported 

The window can be close and QGIS can be used but without the functionality of the processing plugin

Expected results:

A functioning instance of QGIS with access to the processing plugin and no error message.

Additional info:

Problem was fixed by:

dnf install PyQt4-webkit

and opening QGIS again.

Comment 1 Volker Fröhlich 2016-07-30 21:28:15 UTC
Had you installed qgis-python at some point?

Comment 2 Evan 2016-07-31 16:11:21 UTC
(In reply to Volker Fröhlich from comment #1)
> Had you installed qgis-python at some point?

Yes, I qgis python and devel installed.

Comment 3 Volker Fröhlich 2016-08-11 07:33:16 UTC
*** Bug 1362543 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2016-08-11 21:51:13 UTC
qgis-2.14.3-5.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-0ac7bfab00

Comment 5 Fedora Update System 2016-08-11 21:51:21 UTC
qgis-2.14.3-5.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-3146b8f38e

Comment 6 Fedora Update System 2016-08-12 14:27:45 UTC
qgis-2.14.3-5.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-0ac7bfab00

Comment 7 Fedora Update System 2016-08-12 20:52:36 UTC
qgis-2.14.3-5.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-3146b8f38e

Comment 8 Fedora Update System 2016-08-28 08:26:34 UTC
qgis-2.14.3-5.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2016-08-28 13:21:49 UTC
qgis-2.14.3-5.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Rex Dieter 2016-09-16 14:13:24 UTC
qgis/epel7 branch seems to suffer from this bug too (someone in irc mentioned it today).  Can you issue a fix there too?


Note You need to log in before you can comment on or make changes to this bug.