Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1360455 - Navigation from anything under Content menu to QuickStart Cloud Installer->Deployments takes you directly to creating a new deployment instead of the deployment list page
Summary: Navigation from anything under Content menu to QuickStart Cloud Installer->De...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: WebUI
Version: 1.0
Hardware: All
OS: All
high
high
Target Milestone: ---
: 1.1
Assignee: cchase
QA Contact: Tasos Papaioannou
URL:
Whiteboard:
: 1372297 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-26 19:13 UTC by Landon LaSmith
Modified: 2017-02-28 01:38 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-28 01:38:13 UTC


Attachments (Terms of Use)
Screenshot of blank deployment page (deleted)
2016-07-26 19:17 UTC, Landon LaSmith
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:0335 normal SHIPPED_LIVE Red Hat Quickstart Installer 1.1 2017-02-28 06:36:13 UTC

Description Landon LaSmith 2016-07-26 19:13:17 UTC
Description of problem: When navigating from anything under Content to QuickStart Cloud Installer->Deployments, I am immediately take to the New Deployment product selection page instead of the main deployment page that lists existing deployments.  This issue is the same whether or not a deployment exists


ISO Media Version: 1469293134.403192

How reproducible: 100%

Steps to Reproduce:
1. Install QCI
2. Login to Satellite and navigate to Content->Red Hat Subscriptions
3. Navigate to QuickStart Cloud Installer->Deployments

Actual results: You are directed to a new deployment product selection page.

Expected results: You should be directed to the deployment list page

Additional Info: Trying to use QuickStart Cloud Installer->Deployments while on the product selection page, the UI will redirect you to Sat page with the menu bar and no content.

Comment 1 Landon LaSmith 2016-07-26 19:17:22 UTC
Created attachment 1184384 [details]
Screenshot of blank deployment page

Comment 3 cchase 2016-08-03 20:05:06 UTC
Bastion-Katello appears to be intercepting routes using the # and wiping out everything afterwards sending the user to /r instead of /r#deployments.  While they probably should not be doing so, we can enable Ember's support for html5 history to avoid the issue.

Ember.Router.extend({
  locationType: 'history'
  rootURL: '/r/'
...


Rails.application.routes.draw do
  get 'r/*ember_route', :to => 'fusor_ui/placeholders#r'
  get 'r', :to => 'fusor_ui/placeholders#r'
end

Comment 4 Thom Carlin 2016-09-01 12:03:59 UTC
*** Bug 1372297 has been marked as a duplicate of this bug. ***

Comment 5 cchase 2016-09-06 12:40:11 UTC
https://github.com/fusor/fusor/pull/1205

I've changed the URLs to use browser history, so we won't see # in the URL anymore and Katello shouldn't mess with it.  We should navigate to deployments/new deployment appropriately.

Comment 8 Tasos Papaioannou 2016-09-23 14:49:56 UTC
Verified on QCI-1.1-RHEL-7-20160922.n.1.

Comment 11 errata-xmlrpc 2017-02-28 01:38:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:0335


Note You need to log in before you can comment on or make changes to this bug.