Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1360441 - cryptopp needs rebuild for C++ ABI changes
Summary: cryptopp needs rebuild for C++ ABI changes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: cryptopp
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Morten Stevens
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-26 17:56 UTC by Tom Hughes
Modified: 2016-08-05 20:55 UTC (History)
2 users (show)

Fixed In Version: cryptopp-5.6.3-4.fc24
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-05 20:55:39 UTC


Attachments (Terms of Use)

Description Tom Hughes 2016-07-26 17:56:27 UTC
Description of problem:

It seems that cryptopp missed being rebuilt after the most recent C++ ABI changes to you can't actually build against it in F24 as you get errors like:

/home/tom/src/osm/cgimap/conftest.cpp:42: undefined reference to `CryptoPP::OAEP<CryptoPP::SHA1, CryptoPP::P1363_MGF1>::StaticAlgorithmName[abi:cxx11]()'

because the symbol in the library is missing the abi:cxx11 tag.

I have confirmed that rebuilding the package fixes the issue.

Version-Release number of selected component (if applicable):

cryptopp-5.6.3-3.fc24.x86_64

Comment 1 Fedora Update System 2016-07-26 20:38:08 UTC
cryptopp-5.6.3-4.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-49e5ec71b6

Comment 2 Fedora Update System 2016-07-28 05:59:17 UTC
cryptopp-5.6.3-4.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-49e5ec71b6

Comment 3 Fedora Update System 2016-08-05 20:55:37 UTC
cryptopp-5.6.3-4.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.