Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1360416 - RHEV-H and RHEV (RHEL Hosts) OS information missing
Summary: RHEV-H and RHEV (RHEL Hosts) OS information missing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.6.0
Hardware: All
OS: All
unspecified
high
Target Milestone: GA
: 5.7.0
Assignee: Moti Asayag
QA Contact: Ilanit Stein
URL:
Whiteboard: rhev
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-26 16:32 UTC by Kevin Morey
Modified: 2017-01-04 12:58 UTC (History)
11 users (show)

Fixed In Version: 5.7.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-04 12:58:21 UTC
Category: ---
Cloudforms Team: ---


Attachments (Terms of Use)
screenshots (deleted)
2016-07-26 16:32 UTC, Kevin Morey
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0012 normal SHIPPED_LIVE CFME 5.7.0 bug fixes and enhancement update 2017-01-04 17:50:36 UTC

Description Kevin Morey 2016-07-26 16:32:51 UTC
Created attachment 1184328 [details]
screenshots

Description of problem:
After a fresh install of a RHEV environment that includes 1 RHEVM (hosted-engine) and 4 RHEV-H hypervisors. CloudForms for some reason isnt picking up the OS information. It simply just says Linux. This is afecting our out-of-the-box dashboard widget to reflect the OS version as "Unknown". Even after a SSA the hypervisors still has the incorrect OS information. 

To double-check i looked a 4.1 appliance and it looks like the problem is not just related to RHEV-H. Looks like a similar problem exists with RHEL-Hosts too.

Version-Release number of selected component (if applicable):
5.6.0.13

How reproducible:
100%

Steps to Reproduce:
1. Add RHEV provider that has RHEV-H
2. View the OS Information in the Host summary page
3.

Actual results:
OS shows up as linux

Expected results:
Expected to see the RHEL version.

Additional info:
See attached screenshots to see the behavior we are seeing.


Also, here is the OS information form the RHEV-H hypervisors:

$ ssh root@rhev-h1.verimatrix.com
root@rhev-h1.verimatrix.com's password:
Last login: Thu Jul 21 17:43:08 2016

[root@rhev-h1 ~]# cat /etc/redhat-release
Red Hat Enterprise Virtualization Hypervisor release 7.2 (20160627.3.el7ev)
[root@rhev-h1 ~]#

Comment 4 Moti Asayag 2016-08-20 19:11:21 UTC
There are 3 fixes for this bug, as it originated in ovirt-engine (Bug 1368134), on ovirt gem and on manageIQ.

The fix for ovirt-engine:
https://gerrit.ovirt.org/#/c/62627/

The fix for ovirt gem:
https://github.com/ManageIQ/ovirt/pull/67

The fix for manageIQ:
https://github.com/ManageIQ/manageiq/pull/10645

Comment 5 Ilanit Stein 2016-09-19 13:08:23 UTC
Tested on CFME-5.7.0.1.20160913164703_66caf07
Added RHEVM-3.6.9 provider with RHEL & RHEV-H host.

The host's OS displayed indeed fit the actual host OS, but there seem to be a slight problem in the version appearance, as follows: 


* For RHEV-H host, under summary page this is what displayed:
Operating System  RHEV Hypervisor - 7.2 - 20160913.0.el7ev 7.2 - 20160913.0.el7ev

When pressing the above OS version, it opened a new window with this content:
Operating System
RHEV Hypervisor - 7.2 - 20160913.0.el7ev
Version
7.2 - 20160913.0.el7ev


* For RHEL host, under summary page this is what displayed:
Operating System RHEL - 7.2 - 9.el7 7.2 - 9.el7

When pressing the above OS version, it opened a new window with this content:
Operating System
RHEL - 7.2 - 9.el7
Version
7.2 - 9.el7

Moti,
Would you please check that appearance?

Comment 6 Ilanit Stein 2016-09-20 07:53:31 UTC
OS display on CFME seem the same for RHV-4.0:

Tested on CFME-5.7.0.1.20160913164703_66caf07
Added RHV-4.0.4.2-0.1 provider with RHEL/NGN host.

* For RHEL host, under summary page this is what displayed:
Operating System	 RHEL - 7.2 - 9.el7 7.2 - 9.el7

Comment 7 Ilanit Stein 2016-09-20 08:59:59 UTC
OS display on CFME for NGN host:

Tested on CFME-5.7.0.1.20160913164703_66caf07
& RHV-4.0.4.3-0.1 provider with RHEL/NGN host.

* For RHEL host, under summary page this is what displayed:
Operating System	 RHEL - 7.3 - 6.el7 7.3 - 6.el7

On RHV side, here's the host details:
OS Version: RHEL - 7.3 - 6.el7
OS Description: Red Hat Enterprise Linux Server 7.3 Beta (Maipo)

* For NGN host, under summary page this is what displayed:
Operating System	 RHEL - 4.0 - 4.1.el7 4.0 - 4.1.el7

On RHV side, here's the host details:
OS Version: RHEL - 4.0 - 4.1.el7
OS Description: Red Hat Virtualization Host 4.0 (el7.2)

Comment 8 Ilanit Stein 2016-09-20 09:20:00 UTC
Moti,

1. Should this version twice display on a separate bug, be handled on a separate bug?

2. For RHV-4.0 - Do you think we should add CFME, the OS description?
For NGN, CFME display RHEL - 4.0 - 4.1.el7.
but if on CFME,  OS description (appearing on RHV side, see bellow) will be displayed as well,
user will be able to see it's actually RHEV-H, and not RHEL
 
OS Version: RHEL - 4.0 - 4.1.el7
OS Description: Red Hat Virtualization Host 4.0 (el7.2)

thanks.

Comment 9 Moti Asayag 2016-09-20 10:26:26 UTC
(In reply to Ilanit Stein from comment #8)
> Moti,
> 
> 1. Should this version twice display on a separate bug, be handled on a
> separate bug?

It will be handled as part of this bug.

> 
> 2. For RHV-4.0 - Do you think we should add CFME, the OS description?
> For NGN, CFME display RHEL - 4.0 - 4.1.el7.
> but if on CFME,  OS description (appearing on RHV side, see bellow) will be
> displayed as well,
> user will be able to see it's actually RHEV-H, and not RHEL
>  

As for letting the user know about the nature of his hosts:
The ovirt-engine reports the host type which contains 3 values:
1. RHEL - rhel host
2. RHEV-H - the previous ovirt-node / rhev-h hosts
3. Ovirt-node - the NGN

The information will be available on the platform column on the hosts view.

> OS Version: RHEL - 4.0 - 4.1.el7
> OS Description: Red Hat Virtualization Host 4.0 (el7.2)
> 
> thanks.

Comment 10 Moti Asayag 2016-09-20 13:48:30 UTC
(In reply to Ilanit Stein from comment #8)
> Moti,
> 
> 1. Should this version twice display on a separate bug, be handled on a
> separate bug?
> 

Actually, this bug deals with the main hosts tab and version fields.
The additional host information (i.e. operating systems) is covered by Bug 963905), so moving this bug back to ON_QA.

> 2. For RHV-4.0 - Do you think we should add CFME, the OS description?
> For NGN, CFME display RHEL - 4.0 - 4.1.el7.
> but if on CFME,  OS description (appearing on RHV side, see bellow) will be
> displayed as well,
> user will be able to see it's actually RHEV-H, and not RHEL
>  
> OS Version: RHEL - 4.0 - 4.1.el7
> OS Description: Red Hat Virtualization Host 4.0 (el7.2)
> 
> thanks.

Comment 11 Ilanit Stein 2016-09-21 07:42:45 UTC
Moving bug to verified, as now RHEV-H OS is displayed,
and the double version display/Display for NGN host it is a RHEV-H will be addressed in Bug 963905

Comment 13 errata-xmlrpc 2017-01-04 12:58:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0012.html


Note You need to log in before you can comment on or make changes to this bug.