Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1360401 - RFE: support multiple bricks within one process
Summary: RFE: support multiple bricks within one process
Keywords:
Status: CLOSED DUPLICATE of bug 1385758
Alias: None
Product: GlusterFS
Classification: Community
Component: core
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jeff Darcy
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-26 15:31 UTC by Jeff Darcy
Modified: 2017-03-08 15:28 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-08 15:28:39 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Jeff Darcy 2016-07-26 15:31:21 UTC
Advantages:

* Use fewer ports.

* Reduce total memory usage by amortizing the per-process overhead across more bricks per process, allowing us to support more bricks (and volumes) total.

* Reduce thrashing due to having *way* more processes/threads than cores.

* Make QoS easier to implement.

Comment 1 Vijay Bellur 2016-07-26 15:31:46 UTC
REVIEW: http://review.gluster.org/15016 (io-stats: fix translator names) posted (#1) for review on master by Jeff Darcy (jdarcy@redhat.com)

Comment 2 Vijay Bellur 2016-07-26 19:00:28 UTC
REVIEW: http://review.gluster.org/15016 (io-stats: fix translator names) posted (#2) for review on master by Jeff Darcy (jdarcy@redhat.com)

Comment 3 Vijay Bellur 2016-07-29 19:35:40 UTC
COMMIT: http://review.gluster.org/15016 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 9206f5b770bbfc2cf1697f10c1e650cae35272f1
Author: Jeff Darcy <jdarcy@redhat.com>
Date:   Tue Jul 26 08:49:36 2016 -0400

    io-stats: fix translator names
    
    Change-Id: Icf5afaee8b7c704aecab7f8a8a1df9f1bc9288ce
    BUG: 1360401
    Signed-off-by: Jeff Darcy <jdarcy@redhat.com>
    Reviewed-on: http://review.gluster.org/15016
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

Comment 4 Atin Mukherjee 2016-08-02 16:09:29 UTC
I believe this is still WIP as Jeff has another patch up there with topic set to rfc as of now, I am over my mobile so couldn't get the patch link, sorry!

Comment 5 Jeff Darcy 2017-03-08 15:28:39 UTC

*** This bug has been marked as a duplicate of bug 1385758 ***


Note You need to log in before you can comment on or make changes to this bug.