Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1360376 - Import KVM guest image: Import of any Windows VM OS type, failed with "Coding error, pool for requested GUID does not exist"
Summary: Import KVM guest image: Import of any Windows VM OS type, failed with "Coding...
Keywords:
Status: CLOSED DUPLICATE of bug 1359668
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt
Version: 4.0.2
Hardware: Unspecified
OS: Unspecified
unspecified
urgent vote
Target Milestone: ---
: ---
Assignee: Michal Skrivanek
QA Contact: Nisim Simsolo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-26 14:30 UTC by Nisim Simsolo
Modified: 2016-08-02 12:40 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 05:06:55 UTC
oVirt Team: Virt
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)
vdsm.log (deleted)
2016-07-26 14:34 UTC, Nisim Simsolo
no flags Details
engine.log (deleted)
2016-07-26 14:34 UTC, Nisim Simsolo
no flags Details

Description Nisim Simsolo 2016-07-26 14:30:35 UTC
Description of problem:
Import Windows VM (any Windows OS) failed with the next engine.log lines: 

2016-07-26 17:06:34,154 ERROR [org.ovirt.engine.core.bll.exportimport.ImportVmFromExternalProviderCommand] (org.ovirt.thread.pool-6-thread-31) [523a979d] Command 'org.ovirt.engin
e.core.bll.exportimport.ImportVmFromExternalProviderCommand' failed: Coding error, pool for requested GUID does not exist
Version-Release number of selected component (if applicable):
2016-07-26 17:06:34,154 ERROR [org.ovirt.engine.core.bll.exportimport.ImportVmFromExternalProviderCommand] (org.ovirt.thread.pool-6-thread-31) [523a979d] Exception: javax.ejb.EJB
TransactionRolledbackException: Coding error, pool for requested GUID does not exist

and:

2016-07-26 17:06:34,236 INFO  [org.ovirt.engine.core.bll.exportimport.ImportVmFromExternalProviderCommand] (org.ovirt.thread.pool-6-thread-31) [523a979d] Lock freed to object 'En
gineLock:{exclusiveLocks='[17072dbe-cca6-44c4-a8fb-d257e4f106ee=<VM, ACTION_TYPE_FAILED_VM_IS_BEING_IMPORTED$VmName win7_KVM_local>, win7_KVM_local=<VM_NAME, ACTION_TYPE_FAILED_N
AME_ALREADY_USED>]', sharedLocks='null'}'



Version-Release number of selected component (if applicable):
rhevm-4.0.2-0.1.rc.el7ev
qemu-kvm-rhev-2.3.0-31.el7_2.19.x86_64
vdsm-4.18.8-1.el7ev.x86_64
libvirt-daemon-1.2.17-13.el7_2.5.x86_64

How reproducible:
consistently

Steps to Reproduce:
1. Browse webadmin -> Virtual machines tab -> import
2. Select KVM source and enter KVM URI, user and password. click load.
3. Import Windows VM 

Actual results:
Import failed.

Expected results:
Any KVM Windows VM should be importable

Additional info:
engine and vdsm logs attached.

Comment 1 Nisim Simsolo 2016-07-26 14:34:06 UTC
Created attachment 1184284 [details]
vdsm.log

Comment 2 Nisim Simsolo 2016-07-26 14:34:31 UTC
Created attachment 1184285 [details]
engine.log

Comment 3 Michal Skrivanek 2016-07-27 05:06:55 UTC

*** This bug has been marked as a duplicate of bug 1359668 ***


Note You need to log in before you can comment on or make changes to this bug.