Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1360375 - HAWTAPP_VERSION of registry.access.redhat.com/jboss-fuse-6/fis-java-openshift
Summary: HAWTAPP_VERSION of registry.access.redhat.com/jboss-fuse-6/fis-java-openshift
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image
Version: 3.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Rob Davies
QA Contact: Wang Haoran
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-26 14:29 UTC by Brendan Mchugh
Modified: 2017-03-08 18:26 UTC (History)
9 users (show)

Fixed In Version: fis-java-openshift:1.0-16
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-02 16:12:23 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0243 normal SHIPPED_LIVE Update to Fuse Integration Services 1.0 Images and 2.0 Tech Preview Images 2017-02-06 19:55:41 UTC

Description Brendan Mchugh 2016-07-26 14:29:00 UTC
Description of problem:

Openshift 3.1.1 comes with an Image Stream for the java builder image registry.access.redhat.com/jboss-fuse-6/fis-java-openshift

But as it seems within the Image, a referenced version of the hawt maven plugin could not be resolved properly.

# docker run -i -t registry.access.redhat.com/jboss-fuse-6/fis-java-openshift:1.0 env | grep HAWT
		HAWTAPP_VERSION=2.2.0.redhat-070


But this is not available so the build terminates with error.


So a workaround is changing the HAWTAPP_VERSION within the build config to a version available in the maven nexus, e.g.
...
  strategy:
    sourceStrategy:
      env:
      - name: JAVA_MAIN_CLASS
        value: hello.Application
      - name: HAWTAPP_VERSION
        value: 2.2.144
      from:
        kind: ImageStreamTag
        name: fis-java-openshift:1.0
        namespace: openshift
    type: Source

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.
2.
3.

Actual results:

Build fails with error.

I0720 05:04:26.807613       1 sti.go:492] [ERROR] Plugin io.fabric8:hawt-app-maven-plugin:2.2.0.redhat-070 or one of its dependencies could not be resolved: Could not find artifact io.fabric8:hawt-app-maven-plugin:jar:2.2.0.redhat-070 in central (https://repo.maven.apache.org/maven2) -> [Help 1]
I0720 05:04:26.807619       1 sti.go:492] org.apache.maven.plugin.PluginResolutionException: Plugin io.fabric8:hawt-app-maven-plugin:2.2.0.redhat-070 or one of its dependencies could not be resolved: Could not find artifact io.fabric8:hawt-app-maven-plugin:jar:2.2.0.redhat-070 in central (https://repo.maven.apache.org/maven2)

Expected results:

Build should complete.

Additional info:

Comment 1 Ben Parees 2016-07-26 15:15:40 UTC
Kevin, not sure if your team actually owns this image, if not maybe you can push it in the right direction.  Thanks.

Comment 3 Roland Huss 2016-10-14 18:08:44 UTC
The issue is that the RedHat Maven Repo where the productised plugins are lying is not added to the Maven settings.xml.

This is now a quite involved task. In an earlier (developer) version we had the possibility to manipulate our own settings.xml e.g. for setting a proxy server.

However this was abandoned for some reason, so that currently only the user can provide his settings.xml.

The quick workaround for a user it to create a file configuration/settings.xml  in his project directory with this content:

<settings>
  <profiles>
    <profile>
     <id>redhat</id>
     <activation>
       <activeByDefault>true</activeByDefault>
     </activation>
     <pluginRepositories>
        <pluginRepository>
          <id>redhat-plugin</id>
          <name>redhat-repo</name>
          <url>https://repo.fusesource.com/nexus/content/groups/public/</url>
            <releases>
              <enabled>true</enabled>
            </releases>
            <snapshots>
              <enabled>false</enabled>
            </snapshots>
        </pluginRepository>
      </pluginRepositories>
    </profile>
  </profiles>
</settings>

A full solution even would merge this into an user provided settings.xml or set a new settings. Unfortunately, the simplest solution by setting a `maven.repo.remote` property only worked for Maven 1.

So, the fix is not trivial and unfortunately I offline the whole next week but will happily help to integrate a fix after this.

Comment 5 Roland Huss 2016-11-17 13:45:17 UTC
I just added a settings.xml to the Maven installation including a similar profile and adapted the assemble script. The change has been pushed to 

ce-registry.usersys.redhat.com/jboss-fuse-6/fis-java-openshift:latest

the git change is here: http://pkgs.devel.redhat.com/cgit/rpms/jboss-fuse-6-docker/commit/?h=fis-1.0-openshift-java-fuse-6.2-jdk-8-rhel-7&id=e8adc2df9fa6b4cf3da11ab7e124977a25ec0894

The issue should be fixed now. If this could be confirmed I can trigger an OSBS build.

Comment 7 David Simansky 2017-02-01 08:05:35 UTC
Verified, fix present in the following image

brew-pulp-docker01.web.prod.ext.phx2.redhat.com:8888/jboss-fuse-6/fis-java-openshift:1.0-16

Comment 9 errata-xmlrpc 2017-02-02 16:12:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:0243


Note You need to log in before you can comment on or make changes to this bug.