Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1360360 - upgrade python to avoid goferd errors
Summary: upgrade python to avoid goferd errors
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Bootstrap
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: 6.2
Assignee: Rich Jerrido
QA Contact: Peter Ondrejka
URL:
Whiteboard:
Depends On:
Blocks: 1394371
TreeView+ depends on / blocked
 
Reported: 2016-07-26 13:48 UTC by Evgeni Golov
Modified: 2018-12-06 20:49 UTC (History)
5 users (show)

Fixed In Version: katello-client-bootstrap-1.2.0-4
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1394371 (view as bug list)
Environment:
Last Closed: 2016-12-12 17:12:11 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2940 normal SHIPPED_LIVE Satellite 6.2.5 Async Bug Release 2016-12-12 22:08:21 UTC

Description Evgeni Golov 2016-07-26 13:48:11 UTC
Description of problem:
Python on RHEL 6.4 and older is affected by https://bugzilla.redhat.com/show_bug.cgi?id=845802
This leads to a lot of message spam on the consoles when goferd is running.
bootstrap.py should try to upgrade python (as it does with yum, openssl etc) to avoid this issue

Version-Release number of selected component (if applicable):


How reproducible:
100% on RHEL6.4

Steps to Reproduce:
1. bootstrap 6.4 machine to sat6
2. wait till goferd decides to reconnect

Actual results:
connection messages are logged as EMERG and thus on all consoles

Expected results:
connection messages are logged as INFO

Additional info:

Comment 1 Bryan Kearney 2016-07-26 18:53:44 UTC
Moving 6.2 bugs out to sat-backlog.

Comment 2 Rich Jerrido 2016-10-31 14:01:48 UTC
Moving to POST as this commit is available upstream - https://github.com/Katello/katello-client-bootstrap/commit/59124f0b9b2890b0413a6915a75a5b5bb87f07dc

Comment 6 errata-xmlrpc 2016-12-12 17:12:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:2940


Note You need to log in before you can comment on or make changes to this bug.