Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1360352 - [Backport] Race conditions of L3 HA Scheduler
Summary: [Backport] Race conditions of L3 HA Scheduler
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron
Version: 8.0 (Liberty)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 8.0 (Liberty)
Assignee: John Schwarz
QA Contact: Alexander Stafeyev
URL:
Whiteboard:
Depends On: 1281254
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-26 13:30 UTC by John Schwarz
Modified: 2019-02-17 12:19 UTC (History)
16 users (show)

Fixed In Version: openstack-neutron-7.1.1-4.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1281254
Environment:
Last Closed: 2016-08-24 13:30:29 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1770 normal SHIPPED_LIVE openstack-neutron bug fix advisory 2016-08-24 17:29:15 UTC
OpenStack gerrit 227821 None None None 2016-07-26 13:30:37 UTC
OpenStack gerrit 230481 None None None 2016-07-26 13:30:37 UTC
OpenStack gerrit 238123 None None None 2016-07-26 13:30:37 UTC
OpenStack gerrit 257059 None None None 2016-07-26 13:30:37 UTC

Comment 2 Toni Freger 2016-08-08 07:26:29 UTC
Hi John,

We would like to verify this bug, please provide steps to reproduce.

Thanks,
Toni

Comment 3 John Schwarz 2016-08-08 08:06:17 UTC
There are 2 ways to verify this bug:

1. Simply making sure that the patches are there in the latest version,
2. Running a rally test of "create_and_delete_routers.json" with a high concurrency number (10? 15?), and making sure that the exceptions reported do not happen (i.e. all tests pass and the neutron-server logs do not contain errors).

Obviously the second one is better IMO.

John.

Comment 4 Alexander Stafeyev 2016-08-08 12:43:15 UTC
code verification 

[root@controller ~]# rpm -qa | grep openstack-neutr
openstack-neutron-openvswitch-7.1.1-4.el7ost.noarch
openstack-neutron-common-7.1.1-4.el7ost.noarch
openstack-neutron-7.1.1-4.el7ost.noarch
openstack-neutron-ml2-7.1.1-4.el7ost.noarch

Comment 6 errata-xmlrpc 2016-08-24 13:30:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1770.html


Note You need to log in before you can comment on or make changes to this bug.