Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1360335 - Register Host For Updates stays false
Summary: Register Host For Updates stays false
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: Installation - Satellite
Version: 1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ga
: 1.0
Assignee: Jesus M. Rodriguez
QA Contact: bmorriso
Dan Macpherson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-26 12:43 UTC by Thom Carlin
Modified: 2016-09-13 16:34 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-13 16:34:15 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1862 normal SHIPPED_LIVE Red Hat Quickstart Installer 1.0 2016-09-13 20:18:48 UTC

Description Thom Carlin 2016-07-26 12:43:42 UTC
Description of problem:

If Register Host for Updates is set to true, subsequent list of options still display it as false.

Version-Release number of selected component (if applicable):

QCI-1.2-RHEL-7-20160723.t.0

How reproducible:

100%

Steps to Reproduce:
1. Install QCI
2. Log in to run launch-fusor-installer
3. Enter provisioning NIC
4. Change "Register Host For Updates" from "false" to "true"
5. Enter information
6. Examine installation options

Actual results:

* Successful host registration [good!]
* Register Host For Updates false [bad]

Expected results:

* Successful host registration
* Register Host For Updates set to true

Additional info:

It seems as if the host is successfully registered but:
1) it is confusing to an end-user UX
2) it is unclear if there any subsequent *registration* processing that occurs when the user selects "Proceed with the values shown"
3) It runs immediately instead of waiting for "Proceed with values shown" which may be a bit jarring for UX

Comment 2 Jesus M. Rodriguez 2016-08-05 18:13:09 UTC
https://github.com/fusor/fusor-installer/pull/85

Comment 3 Jesus M. Rodriguez 2016-08-05 18:15:37 UTC
Registration has been moved to run AFTER you select option 1 Proceed with installation. If registration fails, i.e. wrong password, customer portal is down, etc. we will exit the installer. You can re-run the installer and choose not to register to get past those errors.

By moving the register to after option 1 selection, we now run AFTER the network has been setup. If the network has not been setup, we fail and drop out of the installer.

The state of register will now show true after you have changed it to true.

Comment 4 John Matthews 2016-08-08 21:56:56 UTC
Will be in evening compose of 8/8

Comment 5 bmorriso 2016-08-17 19:32:51 UTC
Verified with compose QCI-1.0-RHEL-7-20160817.t.0

Register Host For Updates now shows true when it has been changed to true:

"15.  Register Host For Updates | true"

The Host successfully registers for updates:

"
Register this host with subscription manager to the customer portal for updates
Registering to: subscription.rhn.redhat.com:443/subscription
The system has been registered with ID: <REMOVED>

Installed Product Current Status:
Product Name: Red Hat Software Collections (for RHEL Server)
Status:       Subscribed

Product Name: Red Hat Enterprise Linux Server
Status:       Subscribed

Product Name: Red Hat Satellite
Status:       Subscribed

This host was successfully registered!
"

Comment 7 errata-xmlrpc 2016-09-13 16:34:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862


Note You need to log in before you can comment on or make changes to this bug.