Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1360326 - dracut reports ls: cannot access /dev/mapper/mpath*: No such file or directory
Summary: dracut reports ls: cannot access /dev/mapper/mpath*: No such file or directory
Keywords:
Status: CLOSED DUPLICATE of bug 1299800
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: dracut
Version: 7.2
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Harald Hoyer
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-26 12:32 UTC by yuk
Modified: 2016-08-10 12:24 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-10 12:24:10 UTC


Attachments (Terms of Use)

Description yuk 2016-07-26 12:32:29 UTC
Description of problem:

After configuring multipath.conf with

user_friendly_names     yes

# dracut -f

reports:

[root@sgsvrdbora021lx:~]# dracut -f
ls: cannot access /dev/mapper/mpath*: No such file or directory
ls: cannot access /dev/mapper/mpath*: No such file or directory
ls: cannot access /dev/mapper/mpath*: No such file or directory
ls: cannot access /dev/mapper/mpath*: No such file or directory
ls: cannot access /dev/mapper/mpath*: No such file or directory
ls: cannot access /dev/mapper/mpath*: No such file or directory
ls: cannot access /dev/mapper/mpath*: No such file or directory
ls: cannot access /dev/mapper/mpath*: No such file or directory
ls: cannot access /dev/mapper/mpath*: No such file or directory
ls: cannot access /dev/mapper/mpath*: No such file or directory
ls: cannot access /dev/mapper/mpath*: No such file or directory
ls: cannot access /dev/mapper/mpath*: No such file or directory
ls: cannot access /dev/mapper/mpath*: No such file or directory
ls: cannot access /dev/mapper/mpath*: No such file or directory


[root@sgsvrdbora021lx:/tmp]# ls -l /dev/mapper/
total 0
crw------- 1 root root 10, 236 Jul 26 08:56 control
lrwxrwxrwx 1 root root       7 Jul 26 10:30 DONT-USE--X-DR -> ../dm-2
lrwxrwxrwx 1 root root       8 Jul 26 10:30 DR-IOSAVOT03 -> ../dm-12
lrwxrwxrwx 1 root root       7 Jul 26 10:30 IOCAVOT03 -> ../dm-0
lrwxrwxrwx 1 root root       7 Jul 26 10:30 IOPABOOT1 -> ../dm-6
lrwxrwxrwx 1 root root       7 Jul 26 10:30 IOPABOOT1p1 -> ../dm-7
lrwxrwxrwx 1 root root       7 Jul 26 10:30 IOPABOOT1p2 -> ../dm-8
lrwxrwxrwx 1 root root       7 Jul 26 10:30 IOPABOOT1p3 -> ../dm-9
lrwxrwxrwx 1 root root       7 Jul 26 10:30 IOPADAT02 -> ../dm-5
lrwxrwxrwx 1 root root       7 Jul 26 10:30 IOPAFRA02 -> ../dm-4
lrwxrwxrwx 1 root root       8 Jul 26 10:30 IOPALOG01 -> ../dm-10
lrwxrwxrwx 1 root root       7 Jul 26 10:30 IOPAVOT01 -> ../dm-1
lrwxrwxrwx 1 root root       7 Jul 26 10:30 IOPAVOT04 -> ../dm-3
lrwxrwxrwx 1 root root       8 Jul 26 10:30 IOSADAT02 -> ../dm-15
lrwxrwxrwx 1 root root       8 Jul 26 10:30 IOSAFRA02 -> ../dm-11
lrwxrwxrwx 1 root root       8 Jul 26 10:30 IOSALOG01 -> ../dm-16
lrwxrwxrwx 1 root root       8 Jul 26 10:30 IOSAVOT02 -> ../dm-13
lrwxrwxrwx 1 root root       8 Jul 26 10:30 IOSAVOT05 -> ../dm-14
lrwxrwxrwx 1 root root       8 Jul 26 10:30 vg00-lv_backup -> ../dm-23
lrwxrwxrwx 1 root root       8 Jul 26 10:30 vg00-lv_gridbase -> ../dm-26
lrwxrwxrwx 1 root root       8 Jul 26 10:30 vg00-lv_gridhome -> ../dm-27
lrwxrwxrwx 1 root root       8 Jul 26 10:30 vg00-lv_home -> ../dm-19
lrwxrwxrwx 1 root root       8 Jul 26 10:30 vg00-lv_install -> ../dm-24
lrwxrwxrwx 1 root root       8 Jul 26 10:30 vg00-lv_opt -> ../dm-22
lrwxrwxrwx 1 root root       8 Jul 26 10:30 vg00-lv_oracle -> ../dm-25
lrwxrwxrwx 1 root root       8 Jul 26 10:30 vg00-lv_slash -> ../dm-17
lrwxrwxrwx 1 root root       8 Jul 26 10:30 vg00-lv_swap -> ../dm-18
lrwxrwxrwx 1 root root       8 Jul 26 10:30 vg00-lv_tmp -> ../dm-21
lrwxrwxrwx 1 root root       8 Jul 26 10:30 vg00-lv_var -> ../dm-20

Version-Release number of selected component (if applicable):

device-mapper-multipath-0.4.9-85.el7_2.5.x86_64

How reproducible:

Always

Steps to Reproduce:
1. Configure multipath.conf enabling user_friendly_names
2. Run "dracut -f"
3.

Actual results:

ls: cannot access /dev/mapper/mpath*: No such file or directory
ls: cannot access /dev/mapper/mpath*: No such file or directory
ls: cannot access /dev/mapper/mpath*: No such file or directory
ls: cannot access /dev/mapper/mpath*: No such file or directory
ls: cannot access /dev/mapper/mpath*: No such file or directory
ls: cannot access /dev/mapper/mpath*: No such file or directory
ls: cannot access /dev/mapper/mpath*: No such file or directory
ls: cannot access /dev/mapper/mpath*: No such file or directory
ls: cannot access /dev/mapper/mpath*: No such file or directory
ls: cannot access /dev/mapper/mpath*: No such file or directory
ls: cannot access /dev/mapper/mpath*: No such file or directory
ls: cannot access /dev/mapper/mpath*: No such file or directory
ls: cannot access /dev/mapper/mpath*: No such file or directory
ls: cannot access /dev/mapper/mpath*: No such file or directory

Expected results:

<none>

Additional info:

[root@sgsvrdbora021lx:/tmp]# multipath -ll
IOSAFRA02 (36005076303ffd12e0000000000008700) dm-11 IBM     ,2107900         
size=500G features='1 queue_if_no_path' hwhandler='0' wp=rw
`-+- policy='round-robin 0' prio=1 status=active
  |- 1:0:8:1 sds  65:32  active ready running
  |- 2:0:8:1 sdau 66:224 active ready running
  |- 1:0:9:1 sdy  65:128 active ready running
  `- 2:0:9:1 sdba 67:64  active ready running
IOSALOG01 (36005076303ffd12e0000000000008702) dm-16 IBM     ,2107900         
size=200G features='1 queue_if_no_path' hwhandler='0' wp=rw
`-+- policy='round-robin 0' prio=1 status=active
  |- 1:0:8:5 sdw  65:96  active ready running
  |- 2:0:8:5 sday 67:32  active ready running
  |- 1:0:9:5 sdac 65:192 active ready running
  `- 2:0:9:5 sdbe 67:128 active ready running
IOSAVOT05 (36005076303ffd12e0000000000008602) dm-14 IBM     ,2107900         
size=10G features='1 queue_if_no_path' hwhandler='0' wp=rw
`-+- policy='round-robin 0' prio=1 status=active
  |- 1:0:8:4 sdv  65:80  active ready running
  |- 2:0:8:4 sdax 67:16  active ready running
  |- 1:0:9:4 sdab 65:176 active ready running
  `- 2:0:9:4 sdbd 67:112 active ready running
IOPAFRA02 (36005076303ffd08e0000000000008700) dm-4 IBM     ,2107900         
size=500G features='1 queue_if_no_path' hwhandler='0' wp=rw
`-+- policy='round-robin 0' prio=1 status=active
  |- 1:0:4:1 sde  8:64   active ready running
  |- 2:0:4:1 sdag 66:0   active ready running
  |- 1:0:5:1 sdl  8:176  active ready running
  `- 2:0:5:1 sdan 66:112 active ready running
IOPALOG01 (36005076303ffd08e0000000000008702) dm-10 IBM     ,2107900         
size=200G features='1 queue_if_no_path' hwhandler='0' wp=rw
`-+- policy='round-robin 0' prio=1 status=active
  |- 1:0:4:6 sdj  8:144  active ready running
  |- 2:0:4:6 sdal 66:80  active ready running
  |- 1:0:5:6 sdq  65:0   active ready running
  `- 2:0:5:6 sdas 66:192 active ready running
DONT-USE--X-DR (36005076303ffd08e0000000000008701) dm-2 IBM     ,2107900         
size=10G features='1 queue_if_no_path' hwhandler='0' wp=rw
`-+- policy='round-robin 0' prio=1 status=active
  |- 1:0:4:3 sdg  8:96   active ready running
  |- 2:0:4:3 sdai 66:32  active ready running
  |- 1:0:5:3 sdn  8:208  active ready running
  `- 2:0:5:3 sdap 66:144 active ready running
DR-IOSAVOT03 (36005076303ffd12e0000000000008701) dm-12 IBM     ,2107900         
size=10G features='1 queue_if_no_path' hwhandler='0' wp=rw
`-+- policy='round-robin 0' prio=1 status=active
  |- 1:0:8:3 sdu  65:64  active ready running
  |- 2:0:8:3 sdaw 67:0   active ready running
  |- 1:0:9:3 sdaa 65:160 active ready running
  `- 2:0:9:3 sdbc 67:96  active ready running
IOPAVOT04 (36005076303ffd08e0000000000008602) dm-3 IBM     ,2107900         
size=10G features='1 queue_if_no_path' hwhandler='0' wp=rw
`-+- policy='round-robin 0' prio=1 status=active
  |- 1:0:4:4 sdh  8:112  active ready running
  |- 2:0:4:4 sdaj 66:48  active ready running
  |- 1:0:5:4 sdo  8:224  active ready running
  `- 2:0:5:4 sdaq 66:160 active ready running
IOSAVOT02 (36005076303ffd12e0000000000008601) dm-13 IBM     ,2107900
size=10G features='1 queue_if_no_path' hwhandler='0' wp=rw
`-+- policy='round-robin 0' prio=1 status=active
  |- 1:0:8:2 sdt  65:48  active ready running
  |- 2:0:8:2 sdav 66:240 active ready running
  |- 1:0:9:2 sdz  65:144 active ready running
  `- 2:0:9:2 sdbb 67:80  active ready running
IOCAVOT03 (3600507630bffc1760000000000008699) dm-0 IBM     ,2107900
size=10G features='1 queue_if_no_path' hwhandler='0' wp=rw
`-+- policy='round-robin 0' prio=1 status=active
  |- 1:0:0:0 sdb  8:16   active ready running
  |- 2:0:2:0 sdad 65:208 active ready running
  |- 1:0:1:0 sdc  8:32   active ready running
  `- 2:0:3:0 sdae 65:224 active ready running
IOSADAT02 (36005076303ffd12e0000000000008600) dm-15 IBM     ,2107900
size=1000G features='1 queue_if_no_path' hwhandler='0' wp=rw
`-+- policy='round-robin 0' prio=1 status=active
  |- 1:0:8:0 sdr  65:16  active ready running
  |- 2:0:8:0 sdat 66:208 active ready running
  |- 1:0:9:0 sdx  65:112 active ready running
  `- 2:0:9:0 sdaz 67:48  active ready running
IOPAVOT01 (36005076303ffd08e0000000000008601) dm-1 IBM     ,2107900
size=10G features='1 queue_if_no_path' hwhandler='0' wp=rw
`-+- policy='round-robin 0' prio=1 status=active
  |- 1:0:4:2 sdf  8:80   active ready running
  |- 2:0:4:2 sdah 66:16  active ready running
  |- 1:0:5:2 sdm  8:192  active ready running
  `- 2:0:5:2 sdao 66:128 active ready running
IOPADAT02 (36005076303ffd08e0000000000008600) dm-5 IBM     ,2107900
size=1000G features='1 queue_if_no_path' hwhandler='0' wp=rw
`-+- policy='round-robin 0' prio=1 status=active
  |- 1:0:4:0 sdd  8:48   active ready running
  |- 2:0:4:0 sdaf 65:240 active ready running
  |- 1:0:5:0 sdk  8:160  active ready running
  `- 2:0:5:0 sdam 66:96  active ready running
IOPABOOT1 (36005076303ffd08e0000000000009926) dm-6 IBM     ,2107900
size=300G features='1 queue_if_no_path' hwhandler='0' wp=rw
`-+- policy='round-robin 0' prio=1 status=active
  |- 1:0:4:5 sdi  8:128  active ready running
  |- 2:0:4:5 sdak 66:64  active ready running
  |- 1:0:5:5 sdp  8:240  active ready running
  `- 2:0:5:5 sdar 66:176 active ready running


[root@sgsvrdbora021lx:/tmp]# df
Filesystem                   Type      Size  Used Avail Use% Mounted on
/dev/mapper/vg00-lv_slash    xfs       3.0G  1.8G  1.3G  57% /
devtmpfs                     devtmpfs  504G   36K  504G   1% /dev
shmfs                        tmpfs     800G     0  800G   0% /dev/shm
tmpfs                        tmpfs     504G   19M  504G   1% /run
tmpfs                        tmpfs     504G     0  504G   0% /sys/fs/cgroup
/dev/mapper/vg00-lv_tmp      xfs       2.0G   43M  2.0G   3% /tmp
/dev/mapper/vg00-lv_var      xfs       2.0G  993M  1.1G  49% /var
/dev/mapper/vg00-lv_home     xfs      1014M  132M  883M  13% /home
/dev/mapper/vg00-lv_install  xfs        30G   14G   17G  46% /install
/dev/mapper/vg00-lv_backup   xfs      1014M   40M  975M   4% /var/backup
/dev/mapper/vg00-lv_opt      xfs      1014M  548M  467M  54% /opt
/dev/mapper/vg00-lv_oracle   xfs        20G   13G  7.1G  65% /u01/app/oracle
/dev/mapper/vg00-lv_gridhome xfs        20G   13G  7.3G  64% /u01/app/12.1.0.2/grid
/dev/mapper/vg00-lv_gridbase xfs        10G  3.9G  6.2G  39% /u01/app/grid
/dev/mapper/IOPABOOT1p2      xfs       197M  127M   70M  65% /boot
/dev/mapper/IOPABOOT1p1      vfat      200M  9.6M  191M   5% /boot/efi

Comment 2 Bryn M. Reeves 2016-07-26 13:36:51 UTC
This looks like a problem in the Dracut multipath module's handling of systems with user_friendly_names enabled, but with no actual user friendly names configured:

  user_friendly_names     yes

vs:

lrwxrwxrwx 1 root root       7 Jul 26 10:30 DONT-USE--X-DR -> ../dm-2
lrwxrwxrwx 1 root root       8 Jul 26 10:30 DR-IOSAVOT03 -> ../dm-12
lrwxrwxrwx 1 root root       7 Jul 26 10:30 IOCAVOT03 -> ../dm-0
lrwxrwxrwx 1 root root       7 Jul 26 10:30 IOPABOOT1 -> ../dm-6
lrwxrwxrwx 1 root root       7 Jul 26 10:30 IOPABOOT1p1 -> ../dm-7
lrwxrwxrwx 1 root root       7 Jul 26 10:30 IOPABOOT1p2 -> ../dm-8
lrwxrwxrwx 1 root root       7 Jul 26 10:30 IOPABOOT1p3 -> ../dm-9
lrwxrwxrwx 1 root root       7 Jul 26 10:30 IOPADAT02 -> ../dm-5
lrwxrwxrwx 1 root root       7 Jul 26 10:30 IOPAFRA02 -> ../dm-4
lrwxrwxrwx 1 root root       8 Jul 26 10:30 IOPALOG01 -> ../dm-10
lrwxrwxrwx 1 root root       7 Jul 26 10:30 IOPAVOT01 -> ../dm-1
lrwxrwxrwx 1 root root       7 Jul 26 10:30 IOPAVOT04 -> ../dm-3
lrwxrwxrwx 1 root root       8 Jul 26 10:30 IOSADAT02 -> ../dm-15
lrwxrwxrwx 1 root root       8 Jul 26 10:30 IOSAFRA02 -> ../dm-11
lrwxrwxrwx 1 root root       8 Jul 26 10:30 IOSALOG01 -> ../dm-16
lrwxrwxrwx 1 root root       8 Jul 26 10:30 IOSAVOT02 -> ../dm-13
lrwxrwxrwx 1 root root       8 Jul 26 10:30 IOSAVOT05 -> ../dm-14

Presumably these other devices are configured as explicit aliases in the multipaths {} section of multipath.conf?

The error seems to come from the function majmin_to_mpath_dev() in the 90multipath/module-setup.sh script file:

     12 majmin_to_mpath_dev() {
     13     local _dev
     14     for i in `ls -1 /dev/mapper/mpath*`; do
     15         dev=$(get_maj_min $i)
     16         if [ "$dev" = "$1" ]; then
     17             echo $i
     18             return
     19         fi
     20     done
     21 }
     22 

This won't work for anything other than the default user_friendly_names alias pattern; better would be to do something like:

# dmsetup info --noheadings --separator ' ' -c -S uuid=~^mpath -oname,major,minor
mpathb 253 1
mpatha 253 0

Comment 3 yuk 2016-07-27 08:02:11 UTC
Yes, we use things like:

        multipath {
                wwid                    36005076303ffd08e0000000000008601
                alias                   IOPAVOT01
        }

in our multipath.conf

[root@sgsvrdbora021lx:/tmp]# dmsetup info --noheadings --separator ' ' -c -S uuid=~^mpath -oname,major,minor
IOSAFRA02 253 11
IOSALOG01 253 16
IOSAVOT05 253 14
IOPAFRA02 253 4
IOPALOG01 253 10
DONT-USE--X-DR 253 2
DR-IOSAVOT03 253 12
IOPAVOT04 253 3
IOSAVOT02 253 13
IOCAVOT03 253 0
IOSADAT02 253 15
IOPAVOT01 253 1
IOPADAT02 253 5
IOPABOOT1 253 6

dmsetup info seems better.

Comment 4 Harald Hoyer 2016-08-10 12:02:31 UTC
This is actually fixed in the RHEL-7.3 erratum.

Comment 5 Harald Hoyer 2016-08-10 12:24:10 UTC

*** This bug has been marked as a duplicate of bug 1299800 ***


Note You need to log in before you can comment on or make changes to this bug.