Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1360321 - Importing a VM from 3.6 fails
Summary: Importing a VM from 3.6 fails
Keywords:
Status: CLOSED DUPLICATE of bug 1359668
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Backup-Restore.VMs
Version: 4.0.2
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: ---
: ---
Assignee: bugs@ovirt.org
QA Contact: bugs@ovirt.org
bugs@ovirt.org
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-26 12:27 UTC by Petr Matyáš
Modified: 2016-07-27 05:06 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 05:06:19 UTC
oVirt Team: Virt
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)
engine log (deleted)
2016-07-26 12:27 UTC, Petr Matyáš
no flags Details

Description Petr Matyáš 2016-07-26 12:27:32 UTC
Created attachment 1184247 [details]
engine log

Description of problem:
When I export a VM with some snapshots on NFS export domain on 3.6.8-4 and try to import it on 4.0.2-1, the import fails with ERROR [org.ovirt.engine.core.bll.exportimport.ImportVmCommand] (org.ovirt.thread.pool-6-thread-44) [46c81263] Exception: javax.ej
b.EJBTransactionRolledbackException: Coding error, pool for requested GUID does not exist
Although the VM was not in any pool and was created from template Blank

Version-Release number of selected component (if applicable):
RHV 3.6.8-4
RHV 4.0.2-1

How reproducible:
always

Steps to Reproduce:
1. export a vm with snapshots (don't collapse them) on 3.6 engine on nfs export domain
2. attach that domain to 4.0 engine
3. try to import the vm (either with or without collapsing snapshots)

Actual results:
fail

Expected results:
successful import

Additional info:

Comment 1 Michal Skrivanek 2016-07-27 05:06:19 UTC

*** This bug has been marked as a duplicate of bug 1359668 ***


Note You need to log in before you can comment on or make changes to this bug.