Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1360226 - Unable to authenticate to RHEV provider after migration from cfme-5.4.4.2 (3.2) to cfme-5.6.0.13 (4.1)
Summary: Unable to authenticate to RHEV provider after migration from cfme-5.4.4.2 (3....
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.6.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.7.0
Assignee: Marcel Hild
QA Contact: luke couzens
URL:
Whiteboard: upgrade:migration:rhev
: 1366918 (view as bug list)
Depends On:
Blocks: 1370208
TreeView+ depends on / blocked
 
Reported: 2016-07-26 09:40 UTC by Nikhil Gupta
Modified: 2017-01-11 19:51 UTC (History)
19 users (show)

Fixed In Version: 5.7.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1370208 (view as bug list)
Environment:
Last Closed: 2017-01-11 19:51:07 UTC
Category: ---
Cloudforms Team: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2470671 None None None 2016-07-27 13:28:06 UTC

Description Nikhil Gupta 2016-07-26 09:40:46 UTC
Description of problem:

The RHEV provider was added in CFME 3.2 and then migrated to CFME 4.1 by referring article[0]. If I try and change the API port to 443 or blank the test authentication button works. However when I try and save the changes I get the error:
~~~
Endpoints.verify_ssl is not included in the list
~~~

Version-Release number of selected component (if applicable):
cfme-5.6.0.13-1.el7cf.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Add RHEV provider in CFME 3.2.
2. Install fresh CFME 4.1 
3. Migrate CFME 3.2 db to CFME 4.1 following [0]
4. Edit RHEV provider, change API port and try to 'Save'.

Actual results:
Error:
~~~
Endpoints.verify_ssl is not included in the list
~~~

Expected results:
API port should get change and able to 'save' it if credential is valid.

[0]https://access.redhat.com/articles/2327481

Comment 5 Josh Carter 2016-08-18 15:03:23 UTC
*** Bug 1366918 has been marked as a duplicate of this bug. ***

Comment 6 Greg Blomquist 2016-08-18 15:21:43 UTC
Assigning to Marcel to track down upgrade issues.

Comment 9 Marcel Hild 2016-08-23 15:59:55 UTC
I am working on the verify_ssl issue. 

But regarding the port. Should we change the port from 5000 to 443 during an upgrade?

Comment 10 Oved Ourfali 2016-08-23 17:28:48 UTC
I understand that the port 5000 issue was due to a ui issue that we got the default openstack port rather than the rhev one. 
Greg knows about it afair.

Comment 11 Marcel Hild 2016-08-24 14:58:11 UTC
I have a fix for the verify_ssl issue https://github.com/ManageIQ/manageiq/pull/10736

The auth being invalid is because of the port being 0 and not nil.
Greg, is there a BZ for this?

Comment 13 Marcel Hild 2016-08-25 15:00:00 UTC
The 5000 in the UI is being tracked here https://bugzilla.redhat.com/show_bug.cgi?id=1361258

Comment 14 Greg Blomquist 2016-08-29 17:51:19 UTC
https://github.com/ManageIQ/manageiq/pull/10758

Comment 16 Marcel Hild 2016-08-30 13:49:28 UTC
PR https://github.com/ManageIQ/manageiq/pull/10758 in Comment 14 is for another issue.

For the verify_ssl issue 
https://github.com/ManageIQ/manageiq/pull/10758

For the port being 0 issue
https://github.com/ManageIQ/manageiq/pull/10783

Comment 18 luke couzens 2016-09-16 15:39:35 UTC
Verified in 5.7.0.0


Note You need to log in before you can comment on or make changes to this bug.